STL object and intersecting plane

Is i possible to just see the plane and the intersection object part and nothing else (like a CT scan) or do I have to workaround and cut the object and make parts invisible?

Section view should do what you are looking for. :slight_smile:

1 Like

OK thanks and why do you call Fit spline points “control points”? Wouldn’t it be nice to distinguish them fit and control points?

found this in the helps

But why cant I see just the plane and not the engine on the other side, really just and only the intersection. Would sometimes help a lot.

Even if a point is fit to the spline, it’s still a control point, as you have several options you can do with it. E.g. you can split the spline there, or move it. Fit / control is more like the “Type” of how you draw the spline, but both place control points, in a different way.

1 Like

For that I would create a very thin body, and cut the original with it, select intersection, while keep original is turned on. This way if you hide the original body, you will have that intersection.

We might add this capability to section view at some point, but currently it’s not on our close roadmap.

1 Like

ok would be really important from my point of view. I just misdrew a spline as you are not even making the cut surface distinguishable oob. I am drawing on dark grey on even darker grey. Could not imagine worse colors tbh. :slight_smile:

I just cant see where to draw. Looks correct which is not.

Working with STL can be challenging. In many cases if the shape isn’t too complex, it’s better to recreate it in Shapr.

Shapr3D is a solid body modelling software, therefore working with meshes is quite limited.


Well its clearly an optical color problem here, even coloring the cut would make it easy or as said just show the cross section without distractions.

1 Like

If I turn on the section view here on an imported STL-File, the sectioned face turns orange and crosshatched, so I don´t understand why your surface remains grey.

And if grey is not your colour of choice, you might as well change the colour in visualization. :wink:
Cheers Matt

1 Like

It only works if it’s a closed mesh, if it’s open, we can’t generate the filling.

1 Like

@Laci_K thank you for clarification - but re-colouring the meshbody works? I have no open mesh-body at hand.

Matt I see you are closely following my torture with STL :slight_smile:
No honestly a crosssection should be displayed in a different color.
Will try your suggestion with visualisation which is another detour working with STL and a nice workaround.

Yes, colors work in both cases, however you can only color the whole mesh, not parts of it, as technically it’s one face, without edges.

1 Like

But you could color where the plane touches the STL and color that. Feature request hereby. Its hard enough to cope with STLs.

If it’s an open mesh, the problem is, there is nothing to color. It’s basically a 0 thickness face, not a solid body. If you can fix the mesh’s holes, to make it solid, then even the current section view works.

1 Like

What I find strange: Shapr is able to split the body and diplay the split but not color the split surface? What am I surrounding then with control points? Its just barely visible that’s my problem. I mean I get it STL is nothing Shapr can work with but if I can not draw around it, then it gets problematic, especially organic forms that can not be recreated easily. Workaround the workaround would be to slice a second slice below the slice. This gets really a pita and I have to force myself into Shapr lately. Not fun.
Please find a solution for example to set control points at the outmost points of the objects around the object automatically the user can then connect as he likes. CT slice it. To translate the outer object to Shapr would help a lot.

Now the sliced upper part that i set to invisible after slicing will not reappear. I think Im gonna cry now.

Edit: Section view was still active. Now its not a good idea not to show something that it is still on and I did not know it is valid for just all objects on the plate.

Like @Laci_K already said: There is no split-surface due to the fact that there is no “Inside” of the mesh, because it is not closed. No “Inside” means that there is no material that can be computed. In fact the mesh is no body (with a volume) - it is just a shell with zero thickness. If you are still working on the occulus-controller you may try using the file I provided where I gave the surfaces a thickness of 0,01mm - there will be an tiny split-surface visible.