Aligning midpoints

Dear fellow-shaprs,

I wanted to make a short tutorial for another question in this forum and stumbled over a little problem…

When trying to align the midpoints of two circles I fail miserably…
Please point me to where my mistake is.

The snapping to grid doesn’t really help as you see. Disabling doesn’t either.

Thanks in advance

Chris

Short notice to myself :smile:

I wondered why the snapping didn‘t work - neither on the other midpoint nor on the grid.

Using the concentric tool should work, but why don’t the midpoints align?

Cheers Chris

In the vid snap to grid is on, and if it didn’t work after you turned it off is because there is a feature in app which I never liked it but hate! And the feature is that the app keeps the original point in mind when you first dropped the object on! And it really bothers! The problem would be resolved by zooming in or out but not when you do not lock the grid size also😁 which is not the case for you! I mean it seems that you locked the grid size for 0.5 mm

I tried again and found even more strange behavior…

Snapping of midpoints works independent of the snapping-setting, but it is important that the circle itself (the outline) is not selected.

I‘m not sure that this is an intended behavior.

CU Chris

As I said above, the problem would be resolved by zooming in but not when you lock the grid size and snap to grid is on, which is not the case for you! I mean it seems that you locked the grid size for 0.5 mm and snap to grid is on, once you unlock it and turn off snap to grid, by zooming in, you can overcome this strange bothersome behavior, which is intrinsic for the app.
But I prefer to illustrate about that strange behavior simply. See the vids below; first pay attention that both snap to grid and lock the grid size are off. I drew a line from A to B then tried to extend to C but the app doesn’t allow, and the right extremity sticks to its original location but once I zoomed in, I was able to put the end on C.



Not true I think. Even if you keep zooming and zooming the grid will keep dividing and being smaller and you’ll see that you never get to snap to the point like when you are doing concentric constrains for example

You can lock the grid size if that helps. Orientation cube->Lock grid size.

You can see the vid below and see that it is going to be true! :

@Istvan_CEO_Shapr3D

Since Hamed is possibly using the beta-version, did you by chance change something in the beta?

Cheers Chris

Dear Chris

Let me talk on my behalf, I don’t think so, and pls do the following and see if you’ll go to the right point or not:

1- Open a new blank project
2- Turn off lock grid size
3- Turn off snap to grid
4- Draw your two circles

Now test if it works for you

Best

Hamed

This might be a bug in the arrow controls, we will look into it ASAP.

Hi Hamed,

as I wrote above - without snapping activated it works…

The strange thing is that while grid-snapping is activated you mustn’t select the circle-outline to get snapping while moving.

I‘m curious what István and team will find.

Cheers Chris

Actually it’s not a bug, but a UX issue. Indeed when the circle itself and it’s center is selected, it behaves this way. Not great UX. We will address it.

Thanks István,

first of all I‘m happy, that it’s not an user-issue :smile:

Once it‘s known one can adapt to it, but nevertheless it‘s a strange thing and if you‘d find a way to correct it this would be great.

Cheers Chris

2 Likes