Can’t export to Stl?

Never had this issue before. Export to stl fails each time I try. Saving as shapr file works. Have already tried closing and reopening program on my iPad. What are some things that could cause this in a design? Working on this tiny shoe…


Was the initial part imported into Shapr3D as an STL?
If so, suggest you start a new project, import that file and try to export it as STL. If it doesn’t work then I suspect the initial file was corrupt.

No, completely designed from scratch in Shapr3D based on imported photos.

I’m at a loss. Perhaps the Shapr3D team can help out. Your initial image looks quite clean.

I see you have a number of hidden bodies which represent parts of you finished ‘Shoe & sole hollow’.
Try hiding that and go down the line with the different bodies and see if they all export correctly. That is what I would do. Good luck!

Thanks Mike. Seems it is something in that final visible layer. Problem is I have a ton of sketches projected to it then negatively extruded - not sure which is the problem. I will redo all the projections and extrusions onto a blank shoe base, stopping between each to make sure it will still export…

Hey! Could you please upload the workspace? I can have a look at it later this day.

Thanks Peter, but since I had kept all the sketches and a “blank” shoe I already went back and reworked all the details. This time I tried to export after each set was finished and it all worked fine. The only difference is this time I didn’t combine the shoe upper with the sole first before projecting the sketches. I have a feeling one of the negative extrusions around the base of the shoe interacted strangely with the attached sole - but it is just a guess.

For future reference though- what would cause something to not export?

When you export from Shapr3D (or basically any CAD software) to STL, the model you made has to be converted to a mesh model. This conversion process may fail for several reasons and even if it is successful, the STL format tends to have some issues. If your slicer supports 3MF format, please use that one. It is a format with fewer possible issues, but the model still needs to be converted.

During conversion, the most common issue is the CAD model has some small details. These are regularly really really short edges along the intersection of unioned bodies or fillets. If these edges are small enough to meet the tolerance of the CAD-mesh conversion, the process will fail.