Can’t import DWG or DXF

Hi, can you please check if the drawing in AutoCAD is placed near to the origin of the coordinate system? When importing, Shapr3D checks a specific are for the data and if it is placed outside of this area, the drawing is imported as an empty or faulty file.
If your case is different, please upload the file here or contact us at, we are happy to take a look at it :slight_smile:

Can you give us some bullet point rules regarding import and export of DXF files? What you just mentioned regarding origin would be a good start.
I have had a problem exporting, so much so that I had to redraw in another program before sending it off to a a fabricator. I did a test drawing of a simple circle and a simple square on the front plane and tried to export. I only got the circle. So for me, the export seems to be broken but maybe I am not observing some rules of which I am unaware (like what plane must contain the sketch).

1 Like

OK, this is what I have discovered so far… If I just draw any basic shape (on the origin point) in AutoCAD, when I import it into Shapr3D it appears!.. Perfect! However, if I write some text in AutoCAD and place it on the origin, it appears the app can’t see the layer? (See screenshot)
I tried drawing a circle and writing text on the inside, and just the circle appeared when I imported it. Question… Do I need to generate my text file in a particular way or do something else to it for Shapr3D to recognise it??

I will try to get back to this topic in the following days with a small brief about the export/import tricks to help you in the future.
@Lockpro can you please describe what problems did you have?

1 Like

@KPeter_Shapr3D said “I will try to get back to this topic in the following days with a small brief about the export/import tricks to help you in the future.
@Lockpro can you please describe what problems did you have?”

I just posted about my issue as a separate topic, however here it is again.
To test why my sketches were not able to be read by my simple 2D Cad program (DeltaCad, been using it for many many years) I created a simple sketch on the front plane. It is simply a circle and a square. When I try to open the DXF in either DeltaCad, FreeCad, or eDrawings, all I get is a horizontal line and the circle. See the images.

This happens when exported from either the iPad or the Mac desktop BETA.

Here is a link to the DXF file.

Just like I thought

It’s a problem happened to me before while sending a dxf file to a manufacturer

I use DWG FastView and here is the result

I’m sure on iPad it’s the same
It shows the sketch from the side

But in your case I’m not sure what’s the issue but I guess it’s related.

I tried your files to open on my ipad with GnaCad, the result was two lines.
After it i rotated 90 deg to the xy planes, was good.

1 Like

The circle and the square are on the same plane, so it would seem logical that if the circle is showing, so should the square. Further, if you rotate to another axis so the square is visible, then the circle should show only the edge.

I still think something is broken.

I have highligted and rotated togeather 90 deg with the move/rotate tool …

But as I wrote at the first attempt was seen the dia of the circle and the edge of the rectangle…

I figured out a work around.
If a sketch is to be exported as DXF, and imported by another program other than Shapr3D, then make the sketch on the TOP plane.

I took my existing sketch on the front plane, selected all the parts, and rotated it 90 degrees so it is now parallel with the top plane. It exported and, more importantly, opened “kinda sorta” ok in my DXF program. 3 elements of the drawing were far removed from their rightful position and I had to redraw them in the DXF program before sending it off to the fabricator.

Enclosed is a screenshot of the original drawing in Shapr, another annotated to show the problem where features moved during the export, and a link to the original DXF file in case it needs to be examined for defects.


I imported your dxf to S3D ,after I draw a circle in the midle, then exported all of them.
The result is same before without problem.
I think the S3D boys will ansver…maybe compatibility problem wth your dxf program

Thank you for your patience dear people of the forum, let me share some basic info about the dxf/dwg file transfer with Shapr3D.

If you wish to import a drawing, please pay attention to the supported data types which are lines, polylines, arcs, Bezier curves, circles, and ellipses. Annotations, text elements, and 3d objects are not supported. If text elements are exported as curves, Shapr3D is fine with them but you may end up in letters that are defined by ridiculously lot control points - it depends on the software which one exports from.
Another important case which we face quite often is the drawing is far away from the origin. I mean almost 6-700 meters. Shapr3D scans a 1km^3 volume around the origin for imported data, if the drawing is outside of this volume, it will be considered empty.
Layers are supported if they contain planar objects only, their structure can be transferred too if there is a horizontal distance between each layer. Colors and line types will be converted to Shapr3D standards at this time. If there is more than one object color on a layer, the objects imported onto one layer. When separating by colors is needed, you can use the layer filter tool at the beginning of the import process.

Exporting is another piece of cake. Any sketch from any plane can be exported regardless of the orientation of the sketching plane but that can lead to a lot of incompatibility issues.
The best practice is to move/rotate every sketch to the X-Y plane (which can be seen in the Top view, and perpendicular to the Z-axis) before export. In some software, sketches were not shown even on planes that were offset from the X-Y plane.

Because there are a lot of types of curves used in the CAD world, I cannot guarantee that every software will be able to import flawlessly drawings from Shapr3D, but we try to do our best. If you have any issues, feel free to let us know in the future just as you did in the past :slight_smile:

I hope I could help your Shapr3D workflow a bit,

@Lockpro I have downloaded the Top Plane Test.dxf you have uploaded and there were no issues after opening it in Rhino. There should be some incompatibility issue with DeltaCad and Shapr3D :confused:

1 Like

Which brings up a need: reducing control points in curves. Better Bezier tools.


I have the same problem, hence I can’t import DWG nor DXF files. I am running full version Business. I have tired for serval days and with many different files from different suppliers but none is working properly. I will most likely uninstall Shapr3D

Can you please upload them here or send some of the files to Please address it to Peter, I will take a look at them

edit: I have received the files already

Reviving an old thread because I’m in this same boat. Maybe 1 out of 5 DWG/DXF files will import into S3D. Most just time out or show up empty. I bought the business plan for that functionality… If I can’t import DWG files consistently I will be seeking a refund. Any luck with a resolution for this?

Can you please check what drawing elements are in the drawing? I am afraid there are some unsupported ones, which will be skipped during the import :confused:

I have same problem with Import of .dwg format.
The file is huge with multiple layers.
Shapr3D only imports the “empty” ground plane,
and shows the other layers as “unsupported”
Shapr3D needs to say “limited import of .dwg” for the current time.

This file is actually from SKETCHER by Trimble,
a very popular and professional 3D presentation app.
The native format is .skp
This would be a great file format for Shapr3D to import.