Can't edit step file

I have a step file that shapr3d cannot remove a object from. (See attached file)
qqqqqqq.step (2.6 MB)
FRONT you’re looking at the outputs of the ‘airhorn’
from the TOP view you will see a coin sized artifact that bisects a mount ear. That disk cannot be removed, move, deleted, resized etc in Shapr3d.
In contrast Onshape has no problem selecting it as a single object, moving it and/or deleting it.
How in Shapr3D can this disk (artifact) be removed from this airhorn assy?

It can be deleted. I gave the disc and the horn different colors just to seen more easily. Then I moved the disc down and deleted it. I could have left it in place and deleted it as well.

1 Like

This STEP file is quite odd as it is hollow as far as being imported in Shapr3D. It is not a solid body. I’m unable to do a simple extrusion of the face of the mounting flange. I used Split Body to slice it in two areas to see inside.

1 Like

double clicking to select it I get the whole air horn selected not just the disk.
Even from the items menu I can not select the disk by itself

oh now that’s weird! I just downloaded and re-imported that step file I linked above, and THAT copy allowed me to delete the disk! I’d just tried it on my Ipad and the file worked as described above where I had been working on my windows desktop. I sync’ed and fired up my ipad and had the same non-op situation. so DNL’ed the copy above and it works as expected. VERY odd.