Can't set values when clicking the yellow value box

I’m unable to set values. I click on the yellow box with the values in it and the setting dialog doesn’t appear. I’ve watched the tutorial a number of time. Is this a bug? Something I’m doing wrong?

Do you use the Apple Pencil to click on them?

Yoi dob’t have to press, just touch the label.

I’m using an apple pencil. Just touching them closes the value box. I have a single line, I touch the line and the value box appears.The lines showing the width of the line are yellow, the box with the length is tan. No matter how lightly I touch the value box it closes.

Have you upgraded to the latest version? (1.1)

I uninstalled then installed from from the APPStore. Same result. I’ve tried changing the force setting and changing the units. Same result. I see a lot of potential for this app and would really like to get this working. It continues to act like I’m touching on the background when I touch the value box.

Very strange, do you use a small or a big iPad Pro?

Full size (big) iPad. I work a lot with ProCreate on the iPad with the pencil and it seems to work fine. I’ll try to stop by the Apple Store this weekend so I can validate the iPad and pencil are working correctly. From a programming view it acts like the value rectangle isn’t seeing the touch event (obviously, sorry to state the obvious).

Can you try restarting your iPad?

I tried powering off the iPad and restarting it which didn’t resolve the issue. Uninstalling / reinstalling shapr3d again also didn’t resolve it. I finally reset the iPad to factory setting then reinstalled which cleared up the issue. No idea why this worked.

We have a beta version, where we refined the event handling, and got rid of the oress-release to sketch mechanism, maybe as a temporary solution I can add you to the beta. How does that sound to you?

i have the same problem on ipad 12". can t set values und even i cant move the angle ponts of splines. so of cours the program is for me not useful. I really like to use iit. I am visual impaired, but i cant handle it on the ipad. Even the measure boxes are rally not good colored for visual impaired people. I even wwork in inverse mode . there ist much to less kontrast betrween the numbers und the box color.
is there any solution for the problem. I twice installed shapr3d new. restartet the ipad etc.

It is because you are using the iPad in scaled mode. We are going to release a fix for this in the upcoming days, until then you can turn off the zoomed mode in display preferences.

thank you very much for the solution, which works

1 Like


I’m running into the same issue. I’ve just started using the application, but when I create a sketch of a square, click on the face to extrude it, I can get the face to extrude, but I can’t click on the yellow box to give it a value. It just closes. Am I doing something wrong?

Thanks in Advance

BTW: Latest version, downloaded 2 days ago, iPad pro 9.7.

Edit: Forced a restart on the iPad, and its working fine now.

Also forgot to mention that I’m running iOS 10 beta 4, so that might be a part of this issue as well.

I finally reset my iPad to factory settings, installed shapr3d first and it then worked fine. Of course I had to reinstall all my apps as well. I recently broke my iPad and had to have it replaced. On the replacement I installed shape3d first and have had no issues setting sizes on it either. I also use an art program that uses the pencil, wondering if having it installed before shapr3d was my issue?

Shouldn’t be. Actually we noticed that the Apple Pencil can be quite unreliable sometimes, and we really hope that Apple fixed lots of issues regarding this in iOS10. But usually plugging in the Pencil to the iPad, and recharging it helps.

Just an update to this. I’ve been able at times to get it to work but it’s very random for me. Sometimes I have to reboot the iPad, sometimes close the app, sometimes just by switching workspaces, i can get it to edit in the yellow boxes. Sometimes, might take a combination of all three.

App is great and I see great potential. just a couple of minor bugs that I’ve run into.

Thanks in Advance,


It is very likely that these issues are due to the beta OS you are using. We (and most software developers) don’t support beta OS, since they are changing a lot during the beta period. Indeed when iOS 10 will be ready, Shapr will run smoothly on it.