Deleteing lines is deleting objects

Ok this is odd. i have started a new design and once i get the sketch done and extrude a object from a sketch or project a sketch onto another object i cannot delete the sketch lines. if i do it deletes the object i extruded from the sketch lines or the projected object from the sketch lines. also if i try to extrude from sketch lines on the surface of a object any sketch lines in that group disappear. for example if i use add txt and put the word “Front” on a part when i extrude the letter F the whole word disappears as the F extrudes. anyone have this issue and know how to correct it ? Thanks in advance

1 Like

Hi, because first of all your sketch is related(the basis of) to your object and therefore it will be deleted. It can be very smart if the sketch is related to the object so that you can make (and directly see) changes in your design. If you do not want this then you need to merge your modelling steps into the history menu. Also very handy! See below my screenshot.

Why has this just started happening. This was never a issue in the past. Only recently thos has started to happen, aswell as the sketch disappearing when I extrude is a new issue that has never happened in the past. I have changed no settings, these things just started happening

1 Like

It’s because of the recent update, history based drawings.
If you change something like delete a line the body that you created from the line also gets deleted!
I have the same issue as you have, I preferred it as it was before history based version!

1 Like


This is not an issue, this is just perfect freedom of designing. You really have to check some awesome tutorials:( or check 3 lake 3D, he has also very good video’s.

How do you merge?

Click history on the right, at the top click/tap history, select merge in red. You can choose for it to automatically delete all sketches.

It’s clutter in the drawing space is what it is. Alot of unnecessary lines that no longer have a purpose once that part is done

1 Like

I have no merge option in history. It just gives me a list of what’s been done.

Tap the bold history at the top, it should pop up with a menu. If not check the app store and make sure you have the latest version, if not you won’t be able to merge.

ok there is a slightly different setup for merge now. after you tap merge and it opens up the history list you need to click the word history at the top of that window it opens and click the merge button. there is no merge option in red directly in the history list anymore it seams. just updated my software today. and it still moves the whole sketch when you try to extrude and deleted the object created from the sketch on anything done after you merge. so it doesn’t fix the overall issue. id much rather go back to a older version of shapr3d or just simply stop using it completely if i have to deal with this. it adds so much clutter to the work space and adds extra steps to circumvent the issue. once that part of the drawing is done the sketch isn’t needed anymore just modify the object if a change is needed. this is going to end up causing me to find a new design program if I cant get a solution. I don’t like this at all.

1 Like

Chances are, you can fix it in the history panel. When you delete that line, look at the History panel. You should see your extrusion step labeled with :warning:. That means the profile you built the object from has been “damaged” due to your deletion. Expand the step and edit the profile. This is handy if you get further on in your design before you decide to clean up the sketch because, once the profile is fixed, the change will ripple through the rest of your design.

1 Like

Id have to do that every time for every object. That’s alot of extra steps. So the options are clutter work space or a bunch of extra steps.

I usually run it until mine starts to slow down (big files) and then merge steps. For a smaller file maybe once a day would be fine.

Its a shame you cant choose whether to use history based or not to use it at the start of the new project!
Then at least you have a choice!!

1 Like