Drawings have incorrect size in other programs

image
image
image

Still not able to use drawings without manually resizing in other programs. It seems like an issue with metric to AAS (American Arrogant System) conversion to me. My work flow does not require a “drawing” form, just a DXF or DWG file at 1:1 so I can have a part cut on the water jet or importing into Autocad or SolidWorks etc.
I’m making a drawing of a 40” x 50” x 60” object in Shapr at 1:1 but in autocad or SW it’s a different size as you can see in the attachments. (Version 4.6)

Hi!
We would like to check your issue, but we need more info, please help us! What were the exact steps to reproduce the problem? Could you please upload your workspace with the DWG or DXF?
Thanks in advance!

Your result in Solidworks is in imperial (inch)
40mm÷25,4=1,5748031496062992126in
And in Autocad, the equation is in reverse
40mmx25,4=1016mm
It can be corrected in both softwares in the file interface preferences i guess.

Test object.shapr (50.1 KB)
In Shapr, export to drawing, set sheet scale 1:1, place views, save as DXF or DWG.
In AutoCAD, open file, open model tab, then it’s on to resizing. Solidworks is just a simple import.

Pinstriper is correct that it’s correctable, but it’s not an import problem it’s an export problem.
For instance, in Solidworks if you don’t have your settings right when making a drawing the exact problem happens when save as a DWG or DXF. In this case though, I’ve set the drawing to 1:1 in Shapr but there clearly is a translation error to imperial.

Bottom line is that I’m okay with the work around, but if someone doesn’t have Autocad at their disposal like I do and try to export a DXF to a cutting service the file will be the wrong scale.

I just found in Autocad that the file comes through with dimension style ISO-25, and Length scale = 0.0394

Hi!

Thanks for pointing out the issue, we will fix it!

Until then, here is a workaround:

1 Like

Thank you @Laci_Shapr3D for going after a fix, and the workaround is very helpful too!

Any luck with the fix on this? It’s a big deal to have this resolved for any engineering overview of designs originating in shapr3d. Also, a lot more creative opportunities would find their way to shapr3d with autocad as the final destination for printing/notation. I know there are many others dealing with this specific issue. Thank you!

No, this issue seemingly has not been resolved. I’m still getting incorrectly sized DWGs.