Frequent crash in version. 3.52

Frequent crash in new version. 3.52 - iOS version 14.0.1 - iPad Pro 10 5". Happens every few minutes when I try to move hexagons or lines on a plane. The file is not complex at all. The app freezes and I need to switch to another app, when I come back I am greeted by the splash screen.

@Istvan_CEO_Shapr3D

Crashy.shapr (7.9 MB) , here is the file I am working right now.

Yep same here. I had created a simple shape from a rectangle and a circle. I used the move and copy feature when the app froze. Went to a random different app then returned to the splash screen had to select the drawing again then all fine again.

Hi,

Can you please send us a short video of the issue? I just opened your file on a 10.5 Pro with iOS 14.1, Shapr 3.52, and all seems to be fine here.

. Have you tried dragging a line ?

[removing link that didn’t work]

i click the home button when dragging the line stops responding, wait a few seconds and the app already went back to the loading screen. a few seconds later just crashes. it just disappears without any action on my part.

trying again… see my next post downthread.

Hi @nico_h please can you post a short screen recording showing how you drag the lines before the app crashes.

sorry the first link didn’t work.

Thank you, I did some transformation, drew some new lines, and extruded shapes without any unexpected result. Moving the line on the video helped a lot, we will investigate it!

Exactly the same issue here, renders the app almost unusable. It happens when dragging points or arrows, it looked like a snapping bug at first, but it still happens when snapping is turned off. On iOS 13 it didn’t behave like this, I also have iPad Pro 10.5, I’m actually surprised to see so few people having this issue, maybe it’s device specific? An issue with A10X? I uninstalled and reinstalled, reset iPad settings nothing works, as of version 3.53 the bug still exists. Please look into it, looking forward to a solution.

1 Like

Sorry to hear that the app crashes, we have seen this very rarely. Does the issue remain after updating to iPadOS 14.2?

Yes, it is extremely frequent when moving sketched shapes, can provide video or other debug info if you need

I am seeing the same issue with version 3.53.0 on my iOS 14 iPad Pro. This happens very frequently while sketching. I needed to force quit and restart the app to continue, but the issue persists.

Can you please tell me what generation of iPad pros are you using? It may help find the causes a lot

Yeah sure.

Model A1709
10,5 Inch
2017
Wifi and cellular

Model A1709 / MPME2LL/A


512 version

I as well. Most recent update. Most recent iOS. iPad Pro 9.7.

I have a first generation ipad pro that worked fine until the update now it locks up until I hit the home button and restart the app.
Any idea of what to do?

Hi everyone, sorry for the experience. We have fixed some of the crash issues and we are also continuing investigations and looking into finding a fix for these.

1 Like

Hey there,

Same here, app keeps on crashing for no good reason.
iPad Pro 2nd G.

Tried reinstall app, reboot iPad, but it keeps on happening