Issue with subtraction

I am trying to model a pepper mill and the subtraction goes crazy. I used a spline to get the outside shape, then rotated this around the axis 360 to create the solid.

Then I created 2 different size drills (1.5" and 1.75") and extruded them various lengths through the solid. After subtracting the drills from the shape, I am left with some weird thin partial shell line drawing thing.


If you could share the file in .shapr format we could debug the issue.

Here is a link to the file:

Attached is the file. There is the Bottom solid and the Bottom drills I wanted to subtract. When I do, I am left with a couple of solid lines? I tried removing the larger drill solid and I get the result pictured above.

By the way, it’s a great app. Just what I have been looking for over the last 6 months.


1 Like

Thanks, we will look into this ASAP!

So I have noticed a similar issue when subtracting cylinders. Could be related…

As you can see, subtracting a rectangle works great, but the cylinder subtraction is flakey (it worked on the larger upper body)

Hope this helps you guys narrow down the bug!

Found a workaround!

There is definitely something squirrelly with cylinder subtraction on 2.0.4. On a hunch, I tried drawing a rectangle (long cube) and then gave it the biggest fillet I could.

Subtracting my new “almost cylinder” worked great. It’ll keep us going until the bug is fixed :slight_smile:

Interesting, I will take a look, thanks.

We’ve run into similar issues with subtracting
Also when trying to use a flat sheet to slice an object often we have to give that flat sheet/plane volume otherwise the subtraction will not work

Next release should fix most of these issues.

I am having even more basic problems with subractions and have narrowed it down to a very simple case. (This has been driving me nuts for months, literally.)

First I draw a rectangle and make a box.

Next I draw a trapizoid on the side of the box and use the revolution tool to create a conic section (where the top is flat). Finally, I try to subtract part of the conic section from the box.

The subtraction fails every time.

sorry about that, we are going to fix this. I am not entirely sure about what is causing the issue, but it can be that the edge on the side of the revolved body overlaps with the cube. Maybe simply rotating the revolved body around its axis could solve the problem.

I think the problem is that the revolution operation builds a shell made from each individual line being revolved. In my case, I get a top and bottom circle shell and a curved cylinder shell. In fact, I can only select these shell surfaces individually. My theory is that the subtract operation fails because it can’t operate on the shell.

Michael J.

Oh, don’t revolve the lines, but the sketch filling (inner parts)! It will fix the problem.

That’s super important. Is there anything in the tutorials/instructions about that?

Michael J.

Sure, for example in the spatula tutorial, or in the pencil holder tutorial:

It seemed to be a nice feature being able to revolve curves as well, but it turned out that it is not that useful in it’s current state, so we will probably remove that functionality, and won’t even let you select curves for revolving.