Why subtract doesn't work here?

Hello I’m trying to delete a piece of the shape below, in this picture. So I created a rectangle to subtract it from the shape, but I can’t get the subtract function to work.

I can intersect the two shapes, but not subtracting. I can’t understand why.


Please open a support ticket at https://support.shapr3d.com/hc/en-us/requests/new, and attach the project in .shapr format, without it it’s hard to know for sure what the problem is. Thanks!

Although I have a guess :smiley:

In the options keeping the originals is enabled, so there may be the subtracted part and the originals on top of each other. Please check the Items Manager for the bodies.

In order to do the Subtract, the rectangle has to intersect with the lower body. It appears they are two separate parts touching each other but not intersecting which is why the Subtract doesn’t work.

There is intersect: the little shapes on the left are the result of the intersect of the two cloned shapes.

Basically my idea was intersect the two shapes to create the dents. then delete the dents on the original shapes and put the intersected ones on to reposition them.
Tried any possible setting, the “done” button never show up.
Also tried to extrude a bit the vertical faces of the dents instead of moving them, it worked for one, but keep getting “Operation failed invalid result body” on the other one (?!).

Whatever I planned to do, I got stuck at some point and I don’t even understand why. So I kinda given up. Thanks for the replies anyway.

Another project. Another failure on the same operation.
It’s literally just two extruded polygons, and yet. I can’t subtract them.
I’m willing to believe I’m making a mistake, but I’m literally watching the tutorial over and over and doing the same things with very basic objects, just tell me what I’m doing wrong, you even show me the result I wanna achieve, why you can’t just create that shape?! :weary:
This is SO frustrating tbh.

And I can’t open a ticket because I need the pro version to export a project, but why would I buy something when I can’t literally achieve anything with it, even starting from the scratch?

According to your screenshot, the smaller polygon cannot be removed from the bigger polygon because it has been already removed and there is no intersection between the bodies. To check it, just select the body and move it away.

To clarify, I just made a short video which you can find below:

In the first step, the smaller one is successfully removed from the bigger one. In your case, it seems like the option to keep the removed bodies was enabled, so the smaller body remained there after the subtraction.

In the second step, the same tool cannot be applied because there is no intersection between the bodies. Changing the boolean option to keep modified bodies results in the same colors as your screenshot.

Ohhhhh, I was expecting to see the “done” button, as the video tutorial shows. So the subtraction was done already the whole time? :smiling_face_with_tear:
Thanks a lot, you saved my mental sanity.