Latest install on the mac runs out of memory

The latest update for the macOS that I just installed yesterday is a huge step backward in performance. Taking over 5 minutes to move a sketch 10mm. Takes over 10 minutes for my designs to load whether they are really large or fairly small.

My largest design used to take approximately 1 minute to load before I installed the update. How can I revert back to the previous version. Cannot use shapr3d the way it is.

All the symptoms are indicative of running low on memory. Something happened to the app’s use of virtual memory that is not working any longer.

Hi!

Which macOS and app version are you running currently? Could you share the problematic workspace, and the device you are experiencing the problem on?

Thank you!

I am using macOS Big Sur Version 11.6 on a Mac mini (M1, 2020) - 8 GB memory
The macOS version of Shapr3d is 4.12.1.

I can’t tell you what the Windows 10 version of Shapr3d is because I just uninstalled it before reading this post. The reason I uninstalled it is that it seems like it is at least partly responsible for the problems I am having.

I was able to get around the worst part of the problem where my large design was reacting too slow to work with. The following is the story of how everything happened and how I got around it:

My large design, call it mac-large.shapr is being edited on the macOS because the windows version of shapr3d is too slow and can’t export the design back to the file system.

I created a newer small design on the windows version called windows-small.shapr and imported it into the mac-large.shapr design on the macOS. That’s when the response in mac-large.shapr became unusually slow.

To make mac-large.shapr responsive again. I deleted the newly imported bodies from mac-large.shapr. This was successful and it became responsive again. I opened windows-small.shapr by itself on the macOS and exported it back to the macOS file system. Now I am able to successfully use both mac-large.shapr and windows-small.shapr on the macOS with pretty much normal performance.

The only problem now is that it takes 17 minutes to open/import mac-large.shapr when I want to edit it. It used to take less than a minute to open it. Also, I can now import windows-small.shapr back into mac-large.shapr without it causing performance issues, however, the import takes about 7 minutes on a windows-small.shapr file size of 5mb. Just opening the windows-small.shapr by itself takes just a few seconds.

Conclusion:

  1. It is a bad idea to share designs between macOS shapr3d and windows shapr3d.

  2. It seems like there are definitely problems with the new import process, whatever changes were made to it since the last version of macOS shapr3d.

  3. Hopefully the import process can be fixed, otherwise, I would prefer to rollback to the previous version of macOS shapr3d.

  4. I have uninstalled windows shapr3d from that machine so that this problem of file sharing can’t happen again.

Hi!

Sorry to hear that.

Could you share the problematic workspaces? If confidential, you can send it directly to me at laszlo.korodi@shapr3d.com so we can investigate.

What are the specs of the Windows PC you have used?

This is a follow up to this thread. Since my original post, I was able to get my large design working on Mac Big Sur. However, I ran into the following problems with some solutions:

  1. The next day, I upgraded to Mac OSX Monterey. Apparently this version of the Mac OSX uses more memory and I was no longer able to open my large design. My Mac M1 Mini only has 8GB ram.
  2. I decided to go back to using the Windows version of Shapr3d since my Windows pc has 16GB ram. It took forever, but I was able to open my large design and eliminated all hidden and unnecessary bodies and sketches which cut the size of my file by 33%. Now the file loads into Windows fairly fast and I am able to edit it with reasonable responsiveness. However, there is no export to .png function (that I know of) in the Windows version so I am stuck not being able to use Shapr3d as I intended and purchased it for.
  3. I tried loading my reduced file on the Mac (so I can export to .png again), but it only works in Big Sur. Now that I have upgraded to Monterey, the file will load but as soon as you click on any menu, the app locks up (runs out of memory).
  4. It’s very difficult to roll back from Monterey to Big Sur. It takes a whole day and is risky as well.
  5. My problems would be solved it your developers simply enable “export to .png” on the Windows version. As the Windows version is supposedly not a “beta” any longer, I don’t see why this feature has been left out after all of these months.
    In conclusion, I find all of these events a huge inconvenience. I am going to have to spend hours splitting my design into smaller pieces, which degrades the usefulness of your product. Your product enhancements seems to have caused a significant step backward in performance. Also, your porting to different platforms is a disappointment because after several months, the Windows version is still incomplete. In the last 30 days, your product has gone from the best application I have used in years to a huge disappointment.

Hi @wallinrew, I’m really sorry to hear that. Shapr3D for Windows is still in Early Access phase, and it’s catching up quickly with the other platforms. We are working very hard to achieve feature parity, you can expect almost 100% feature parity across all platforms early next year.

Also, if you could share the file with our support@shapr3d.com team, we’d love to take a look to see what’s wrong.

Thanks for your quick response on this matter.

Most likely, emailing the file will fail as it is well over 200MB. I would require a cloud drive that I can drop it on. I would have addressed this a long time ago, but as I mentioned, I corrected the problem a couple of times using different methods.

Problem is that it seems unusually sensitive to changes in Shapr3d versions and Mac OSX versions and keeps coming back.

If you get in touch with our support team, they’ll provide you a cloud link where you can upload it. Thank you for your feedback and your assistance.

Ps.: meanwhile we optimized loading times, with the latest version of Shapr3D tessellation data is cached, thus from the second time the workspace should open much faster.