S-L-O-W Load Times, Are my files too large?

My creations are taking FOREVER to load, like 40-60 minutes! Or not loading at all, once they get too large. I am making elaborate victorian houses to 3D print in miniature. My most recent project is 720,000KB. Does anyone else have this problem? I switched from using an ipad to a brand new laptop and still have problems.


1 Like

Might it be that you have many sketches included in your design?
I found that having many will seriously slow down loading and editing designs.
Removing unneeded sketches will speed up the process

Its not about the drawings. I have tested with many drawings + with many devices. Somewhere is something wrong!

1 Like

Hi All,

Might it be a memory issue? Large sketches need to be broken down in size to handle, noted from experience. Planning on going from present 16MB to 32MB and or 64MB memory. Moving to a Desk top Mac instead of laptop.

Can’t say about the iPad, as not presently using one extensively.

I also noticed that the longer the App is open the slower she gets, shutting down everything else helps.

Thank you, that does seem to help a tiny bit but I am still surprised by how long it takes. I can’t believe my house drawings are more complex than an engineer or architect using the app. I am just a hobbyist making 3d printable dollhouses, basically.

Do you have an exemple to show ?

1 Like

Hey @CarynNotKaren,
Please send us the Shapr3D design in a support ticket using the link below, we are happy to check. Please don’t forget to let us know the version of Shapr3d and the specs of the device you are using.


1 Like

Is that a 720mb file size? If so, I think that’s going to take a while to open on any iPad.

I usually start my projects on my ipad and once they get too large and start crashing I start working on my laptop. Submitting official ticket now.

1 Like

I have almost the same issue but it takes only like 20 sec most but this happends to me often when i have big importet mesh bodies like gears.

Yes! My experience too! I tried to make a “voxel theater” of 100x100x100 tiny cubes (just showing outer faces; ~60,000 tiny cubes), and it will take literally 30 minutes to open with a state-of-the-art desktop running Windows (with Radeon 7900 XTX graphics card, Ryzen 5600 CPU). And once you’re stuck in the opening loop, you just have to close the program and try something else. No backup to allow you the option to decline in the case that opening will take 30 minutes.

That’s quite tough for a CAD system. Typically CAD systems are not very good at things like this, a 3D graphics software is more suitable for the job. We we’ll release performance optimizations this year that will make similar operations faster, but this is not a sweet spot for CAD technology.

1 Like

Yes,I have the same problem like you are. I just draw a simple drawing ,it is not big project. I use iPad Pro 16 GB Ram and 1TB storage. If it very slow to open project like this. I think it can not use to do the business .

Hi All,

A short update.

For some reason I have noticed improvements with the handling of the very large sketches that I am working with, they seem to now be easier to handle. But I am still wondering about this issue and it would seem it’s not the internal ram and of the chip set but more about the Apple GPU.

I have an intel based 2019 MBP with 16GBs of internal storage and 1 TB SSD. But I think the AMD Radeon Pro 5500M 4 GB Intel UHD Graphics 630 1536 MB is on the low side, (should have paid more for a better card at the time). But seeing caldwbr’s use of a Radeon 7000 XTX graphic card made me wonder further.

I recently purchased an external GPU to experiment further and will update once it’s all set up. I’m presently leaning on this being an Apple GPU issue. Some said a 32 core GPU or higher is required to do intensive graphics and CAD work.

Will update again once I have the eGPU in place.

I wrote a project It turns out that editing slows down. I check the memory used is 422MB. So I removed item details from 70% of the work. then save again It turns out that the software also saved the job with 422MB of memory. Makes opening the file again takes a very long time. In the past, I couldn’t work on a project that was very detailed. causing the software to not work as expected I probably won’t be able to continue using the software again.

If you contact our support team, they’ll be able to help.

I’ve discussed this issue with a supporter,but was advised to reduce the number of duplicate items only.

This is my project which removes 70% of the item details but when saving the file The file size is still the same size, 422MB.
So I would like to ask what is the cause of this problem?

Unfortunately I don’t have access to the file.