Measure in cura

Hello ! When I put my stl files on cura they appear very little. Why ?

Hello! The main reason I think is Cura expects every imported model to be in millimeters. Can you please set the Units in the Advanced settings of the STL export window to mm and give it a try?


This article might help :slight_smile: It’s probably caused incorrect units used.

Thank you so much ! It works :relaxed:

1 Like

You guys really need some sticky posts.

1 Like