3D printing STL export issues

For some reason I’m having to export my .stl as mm out of Shapr if I want Cura or Prusa slicer to scale correctly.

Even having prusa slicer set to inches will result in mm import from shapr. I think Shapr just has the values crossed in their code.

Please fix.

Issue on both IPad and Windows versions.

1 Like


STL files do not have a dimension stored in them, it may happen that the slicer expects different units. Let me share an article and an older forum post about this case, I hope you will find them helpful:

In the meantime, if you are exporting files for 3D printing, please use 3MF format. It has fewer possible file issues and can store important data like measurement units while STL transfers only the geometry in a quite old format.

1 Like

Why does shaper have the advanced option to select export units and why does switching from inches to MM resolve the scaling issue?

Did you miss the follow up question I had perchance?

edit: oh it looks like I didn’t ‘reply’ to you correctly, that would explain it haha

My bad! STL format transfers the geometry in a unitless format which can be a problem if the slicer automatically expects these units to be millimeters for example. In some cases there is no option to change the expected input format, so with this unit option, the coordinates are scaled according to the set unit to make sure the dimensions of the imported geometry will match the dimensions of the original geometry.

3MF does not have this problem as it transfers several other info, like the applied units of the geometry.

1 Like

Ah there you go, thanks for the details. Also, I have been happily using 3mf since you suggested it by the way. Muuuch better experience haha.