My entire account seems to have vanished

I had been using a student license on Shapr3D on my iPad since last year. Everything worked fine on my device.

Today, I tried to connect to the app, through my device, and instead of connecting automatically to my account and to the menu page, it redirecte dme to a connection page.
Here, I tried to connect using my email and password, and it told me “wrong password” despite being sure of it.
I tried to reset my password then, but it did not work, as not a single email landed in my inbox.

On the forum, I learned that my email is not linked to an account, seemingly.
So I am talking from a “new” account created from the email of my previous one.

The thing is, I lost access to ALL OF MY PREVIOUS FILES. This obviously is causing me much trouble at the moment.
If someone has any idea of what happened/how to solve it, please do share it.

Best regards.

Hi! I located your Shapr3D license under the email address you registered here on the Forum. Can you please try to log in? You can ask for a password reset email from here if needed. In case this doesn’t solve your case, please open a support ticket. Thanks!


Somehow my password seems to be working now, so I managed to retrieve my
Nonetheless, despite numerous tries at recovering my password, I still
have not received a single password reinitialization email since I tried
to do so (30 hours since I first requested a password reset). I am glad
that my password works once again, but the issue with the password reset

Best regards