Pdf export failed

Dear all,

i tried to export my 2D drawing as pdf, but it failed.
I never experienced this before.
Even after restart it failed.
Any Ideas?

Shapr business on windows 11

Export failed.pdf (104.2 KB)

Hi Moritz,

Try exporting the file to another destination, it may be write permissions on servers etc. especially on some companies.


Hi Robert,

failed again.
I tried to export also dwg and DXF. Fail

Hi @Moe! We would need some more info about the issue, a screen recording could help a lot. Please also let us know the export path, I tend to agree with @Robert on the permission issue.

If any of the details that I’ve asked above contains sensitive data, please feel free to open a support ticket at the link below:

1 Like

Thanks, got it! Could you please upload the Shapr3D design also? I cannot see any issues with the file, nor the path.

Thanks, but I’m looking for the exact Shapr3D file that you are working with to reproduce the issue. Please export your design as a Shapr3D Design and upload/send it to us.

Ah, sorry. Here you go:
Sealing.shapr (83.9 KB)


I reproduced your problem: as soon as you add a cross section view in the drawing with your design, you can no longer export the pdf.

The root cause of the problem is a weird geometry in the design (but it should not prevent from exporting the pdf, so there are actually also a corner case’s bug in drawing :wink:).

If you make a cross section and zoom you will see there is actually a small hole in the design.
Best way to fix your design is to split the body, project the section on a plane, trim the unwanted lines, and create a clean body by revolving the cross section.
Then you will have to re-create the drawing and the dimensions, but it will export in pdf.
I made a short video showing the process.


Thanks Pec,
You made my day!

You’re welcome.
As I also need pdf export for my workflow, I was a bit worried by your issue, so I had a quick look as the design was not too complicated.