Problem unloading to Shapeways

I recently tried to upload a file to a company called Shapeways which seems to specialise in printing 3D models. Unfortunately it did not go well. I tried in both .STL and .OBJ formats, but received error messages in both instances. One of them contained the following:

‘Unfortunately, the model you recently uploaded entitled Circumvolve did not pass our initial printability checks, so it’s not yet ready for 3D printing. Printability Error:

  • Automatic rescale failed. Model is not within acceptable bounds in any unit. When rescaling to units in:
  • millimeter, model is 1.91439 x 0.27416 x 0.01437 m
  • inch, model is 48.62548 x 6.96367 x 0.36498 m
  • meter, model is 1914.38892 x 274.16025 x 14.36932 m’

Another simply stated:

‘Model is not manifold.’

The file should contain data defining two interlocking pieces, the basic shape of each being an irregular L shape. The rough dimension of the shape should be 54mm x 108mm x 5mm.

I am based in the UK

Any advice would be very welcome.

Hi Neil, thanks for reaching out. Please can you upload a screenshot showing the model you are trying to export. This will help us better understand and investigate the “non-manifold body” error message.

The STL format does not contain units. Under the advanced STL export settings, you can set the units of the STL file to any unit. I assume Shapeways expects the STL file units to be in millimeters.

Thank you for the quick responses. Just received an email saying they are now able to access the model file so it appears it was a false alarm, but I hope you won’t mind if I come back to you if the issue proves not to have been resolved. Best wishes. ANW

1 Like

Glad to hear that, happy to help anytime :slight_smile:

1 Like

Me again. I’ve heard back from Shapeways. They say I have manifold issues and have sent me this link to help me resolve them.

Unfortunately none of the video links which are alluded to seem to appear on either my iPad or iPhone. I will try looking on a PC later. In the meantime I get the gist that either there is a hole or a hidden face, but after spotting nothing on a cursory glance I’m not sure what to do next. Any advice would be welcome

![image|666x500]I have included an image which may or may not be helpful. Happy to share the file if that is more useful. Many thanks in advance. Best wishes, Anthony

Hi Anthony, sharing the file with us will be helpful in this case. Please send the design file to and we are glad to help find what brings about this error.

I’ll do that now and mark it for your attention Victor. Many thanks, ANW

Also you can try applying the union operation(Union Tool) on overlapping bodies. This can also help you find bodies not properly intersecting if there is an error while trying to union them.

I’ll have a go. I’m pretty new to this, but your tutorial videos have been so encouraging. I may have tried to run before I could walk so feel free to be honest with your assessment. If you think I should go back and start from scratch then please do tell me. I have found your software a joy to work with and much more intuitive and versatile than other platforms I experimented with. Best wishes, ANW

It’s great to hear that you enjoy working with the app, this means a lot to us.
If after you try to union the body faces the issues persist please send us the design file. We are glad to assist you in finding the fastest and most efficient way to achieve your desired results using the app.

I have some questions is there a way to save shaper file not in a zip folder so I don’t have to download another app to unzip the file before I view it in 2d in another app on my iPad ? But hands down I love Shapr3D I would recommend it to any one!

Hi, I misunderstood your request, I apologize. Turn off the “Save each first level item into a seperate files” in the export window as shown in the attached image. This way the output file is not compressed.

Okay. I have a couple of follow up questions. Firstly were either of the last two exchanges anything to do with my initial question or was that a separate issues that was being addressed? Secondly I have tried using the union tool, but both pieces seem to respond as they are already integral bodies. Having watched the water bottle tutoring video I have taken the advise of saving various versions of my design, step by step meaning that I should be able to retrace my steps without having to literally start from scratch, so I was wondering if there was a way to progress, but checking as I go whether the latest version is ‘manifold’. Alternatively is there a way I can pay for someone who knows what they are doing to locate the error? Many thanks for any advice you may be able to offer. Best wishes, ANW

The last two exchanges was a different question asked by the user. Please, can you send us the design file - we will be glad to take a look to find workarounds. We didn’t receive the file yet. You can send it via email to or to

Apologies. I had been sending the via a problematic email app. Hopefully now you should have it. The email and the file are named Circumvolve. Many thanks, ANW

1 Like

Hi Victor, Did you receive the file successfully? We’re you able to make sense of the contents? ANW

Hi Anthony, yes I received the workspace. I escalated the issue and I will get back to you as soon as I get feedback. Thank you for your patience.