Non-manifold detection

I’ve created a model that I was getting ready to 3D print.
I’m getting a warning :warning: in the slicer software (Lychee) that the STL is non-manifold, and I cannot find what might be causing the error in the original model created in Shapr3d.

I know that if you are in the process of modeling a feature in Shapr that is non-manifold, it will give you an error message. I don’t recall that happening though.

Is there any tips or tricks to find non-manifold geometry?

Thanks.

For starters, is the body you exported one solid body? Meaning, it not composed of more than one body that have yet to be UNIONED as one.

@TigerMike yes, I did verify that it is one body.
A couple days ago it wasn’t because I did not know it would be an issue, so I tried it as one complete union, still no luck.

Part in question.

A1F7BF15-3391-41B8-8DF9-E4B8B1B8D5BF_4_5005_c

Thanks

You moved the body and there is nothing else that exists in that space? Try making it transparent and look for internal anomalies?

Try splitting objects/parts in Lychee and see if something reveals itself.

@Oregonerd I guess I can split the part into multiple pieces, import them individually into Lychee and see what body has the problem.

And yes, there are no other bodies.

A good tool for checking manifold issues is MeshMixer. It has an analysis mode where it will identify non-manifold and other issues.

@TheBum thanks, I’ll give that a shot.

@TheBum It totally worked great, thanks!

Turns out there was a surface non-manifold issue AND a hole issue, that I NEVER would have found.

One click and both were fixed. I imported them into the slicer and the errors are gone :+1: :+1: :+1:

2 Likes

@NathanD where in the model did you find the non-manifold issues?

@Istvan_CEO_Shapr3D these were the errors pointed out in mesh mixer.

I then went back into the model in Shapr, searched, and found it.

This is what I found viewing “inside” the part.

Like I said, I would have never found it. :woozy_face:

2 Likes

How did you rectify the last one?

@Oregonerd mesh mixer has a repair function for the mesh body. One click fix.

I have not tried to fix the Shapr model.