Shell refuse create hollow object

I have an object of fuel tank mock-up and recognize some buggy behavior.

See the image, hope it describes my problem. Any advice would be appreciated.

Edit: the bottom object is possible to transform to shell, but only up to 6 mm thick walls

The middle is not possible to transform to shell.

I cut the pieces I thought could be problematic and tried transform only the remainder object. For some reason only 2mm thick wall is possible. The tool shows preview for 6mm thickness but then it refuses to transform again

For three times I encountered app crash as well

Apple iPad Pro 2020

I tried to split the boss along the axis of symmetry - I managed to create the shell from one half bot not from the other …

1 Like

What thickness are you trying to achieve?

I’d like to make a suggestion?

If one half worked when you split it along the axis of symmetry then…

  1. Delete the ‘bad’ half.
  2. Mirror the ‘good’ half
  3. Union the two halves.

…then you’ll have a complete model shelled successfully :wink:

I did exactly this. But it seemed I was kinda more lucky than anything else that i did not stuck with no option at all.

If anyone have systematic solution it would be good to know.

10mm, the whole object is 200x350mm so there is plenty of space to manage the shape

Hey @JakubUrban! The shell tool prefers simpler shapes, applying the tool on complex polysurfaces may not result in a solid body - which I think is the problem in this case.
The crash also should be strictly connected to the complexity of the model, Parasolid tries to solve the issue then it runs out of RAM.

There was a similar thread at the beginning of the year, let me share it with you:

But, did it work though… mirroring the good half ?

Yep, solved through this.

1 Like

I’m glad you managed to solve it.

If my suggestion helped you solve it then I’d be most grateful if you would ‘like’ my post and mark as ‘solution’.

Thanks :smile:

1 Like

I was investigating this one a little bit more and found this:

the object was created as a merge (and a substraction) of more objects/sketches.

where i found the possible core of the problem is this

imagine a section view through and object - you can see the outer edge. This is the result of merging (union) a subtracting, etc. The edge is not defined as an continuous curve, but as a series of different curves - this is ok so far

the problem is, that these curves seems to be defined differently regarding “inside” and “outside” view. Best view of this is, when you try the “offset edge” function - you drag the arrow outside, but some of the lines goes inside …

from my point of view this could be the problem when creating shell on complicated parts - even if from human point of view the shell is quite simple and there is no apparent conflict

it is just my specilation, sorry if its totally out …