Solved: Adding own fonts for the new text tool

Hi there!

Since I wanted to use my own fonts in Shapr3Ds new text tool, I was looking how to import fonts natively to iPadOS, so that they can be used in any app (incl. Shapr3D).

Maybe the following solution is valuable for others too…


  • I downloaded the app „iFont“ from AppStore to my iPad

  • Was creating a profile of my desired fonts (could import my own fonts) and installed them with „iFont“ (there are very clear instructions available in iFont)

That‘s it. :slight_smile:


Installed fonts using iFont but new fonts don’t appear on text tool. I’m able to use the installed fonts on all apps except Sharp3d. Any ideas?

Are the newly installed fonts showed under the tab ‚Installed‘ in iFonts?

1 Like

yo la solución que encontré fue, abrir cualquier aplicación donde se pueda escribir con distintas tipografías y al usar las importadas ya te aparecerán después en shaper 3d

1 Like

I’m having the exact same issue. Shapr is not displaying my downloaded fonts, but other apps are.

I still have the Text to Drawing app, which is displaying and using those custom fonts, which I can import to Shapr, so for the time being I have a workaround.

1 Like

Solution posted by @wigarga solved as another temp fix. Open/Use downloaded font in another program. I used Affinity Designer. Open text tool on Sharpr3D and downloaded font should be on recent fonts.


Hi all and thanks for your feedbacks.

I realized what you‘re meaning. It seams to be an issue in Shapr3D. Since I used the fonts already in other apps, my newly installed fonts have been displayed under „Latest“. As you‘re writing, the issue is, that Shapr3D does not really read all installed fonts, but shows them under „latest used fonts“.

So we have to live with this work-around:

  • open the font in an other App first

@Istvan Would you please have a look to this issue? Shapr3D will surely finde a solution for this Shapr3D related issue, right?


We are aware of the problem on iPadOS, and a fix is already being developed, sorry for the inconvenience!


It’s been a year and is doesn’t seem to be fixed. The workaround with using different app first doesn’t work for me either.

1 Like

Hey @sjirka, the Text tool in Shapr3D should recognize all the fonts you have installed on your devices. Please check if you have the font installed and if you run the latest (5.300) version of Shapr3D then let us know how it goes.

If it does not work, please open a support ticket using the link below and send us the font with a screen recording where it can be seen as an installed but not recognized one. Thanks!

1 Like