SpaceMouse - Definitely needs lots of practice!

I’m so happy with my SpaceMouse but I definitely need more practice using it…

I switched off ‘Dominant’ but it still seems to focus on the nearest body and makes navigating a little jerky and unpredictable at times.

The video is ‘speeded up’ and is exaggerating the jerkiness a little (a lot) but although I can normally orbit a single body really smoothly in this case it seems to lock on to other bodies that are closer and makes navigating the scene really difficult.

If you’ve seen my earlier SpaceMouse video you’ll notice it’s a lot smother.

Does anyone else have issues navigating when close to other bodies?

1 Like

Try this :smirk:



1 Like

Also guys, can you scream with me on 3Dconnnexion to release an usb-c port/bluetooth space mouse? They act like dead.

Or somebody release one ! Please!

Also there is an in-app setting for Space Mouse

1 Like

I tried changing all of my settings to match what you have but it made no difference so I reverted back to the original settings.

I don’t have access to the in-app settings. ‘SpaceMouse Settings’ is greyed out…

I don’t have any issues navigating the sample model in 3DConnexion Viewer…

In the second part of the video I try to navigate between the red and green blocks but the camera tries to hug the the wall of the green block and ends up like scrambled spaghetti :astonished:

I tried switching to ‘camera’ instead of ‘object’ in the settings so that it doesn’t ‘latch on’ to a particular object in the scene but it’s notoriously difficult to navigate in this mode and still seems to slow down and hug the wall of an object as it approaches.

I think shapr doesn’t recognize the space mouse as it should. Try figuring this out. Uninstall 3DConnexion software/plugins and fresh install? Maybe for Shapr too? Unless you found something else.

From my experience on other cad softwares, is working as it should on Shapr on my side.

What do you mean by Shapr3D does not recognize the space mouse as it should?

In the meantime please note that removing Shapr3D will remove your designs also. Before removing Shapr3D, always create a backup of your designs!

@KPeter_Shapr3D, @Do.B,

I’m not entirely sure what’s going on. I realised this morning that it’s not just the SpaceMouse that is behaving strangely. I’ve had issues with the trackpad on my MacBook Air M1 also. I have been unable to pinch to zoom and occasionally have had issues panning or shift/rotating.

Closing Shapr3D and restarting the app seemed to resolve the issue and I was able to continue modelling for a short time until it all went crazy again and needed another close and restart of the app.

The issue still persists though with the SpaceMouse in that I can’t navigate close to an object without it slowing down and hugging the wall of the object.

But these issues only happens in Shapr3D and do not happen in the 3DConnexion viewer where I am able to comfortably navigate through the sample jet engine without any of the issues above.

Likewise, I don’t experience any issues with the trackpad in any other app.

1 Like

Weishsteve said the in app setting is greyed.

Hi

Issue with trackpad zooming and pinching seems to be a macOS bug.
I encounter it from time to time, and it’ a known bug on Apple’s forum. Happens also on preview and others apps.

Workaround for me is simply to close the screen of my MacBook Air M1 for one second so the computer enters sleep mode and reopen it. It restores the trackpad without having to quit Shapr3D.

Best
PEC

2 Likes

Thanks for this. I’ll try it next time I have the issue.
I won’t mark as ‘Solution’ until I’ve tried it.

Just happened this second. My model seemed to freeze and I was unable to pan or zoom.

I simply closed the screen and opened it up again and I’m able to pan and zoom again.

Thanks for the tip :ok_hand:

You’re welcome.:grin:
This bug was driving me creazy until I found this workaround.
It happens more often when you are using several apps with zooming gesture and you are switching between them.

1 Like