Spacemouse support for windows?

Does shapr3d support spacemouse on windows?

1 Like

Not right now, at the moment we only support it on macOS. Some of the technologies we’re using are difficult to reconcile with a specialized hardware like the SpaceMouse, but we’re on it. If all goes well, it’ll be released in a few months.

1 Like

Any progress on this?

We’ve managed to find a reliable solution for the problems we were facing, and we’re working on the implementation as we speak. It should land in a release in a month or so unless we run into some unexpected issues.

OK, thanks. I hope it is sooner rather than later!

SpaceMouse on Windows support is now available with version 5.210. Make sure you check it out and let us know how it works!

Generally, seems to work well. Trying to figure out how to make the buttons work for ‘shift’. Doesn’t seem to stick. Changing the zoom from forward/backward to up/down also doesn’t seem to work yet

Thanks for the quick feedback!

Which SpaceMouse are you using? Also, could you post a screenshot if the settings screen when you’re setting up the button shortcut and changing the zoom settings? I’ve just checked and both seem to be working well on my SpaceMouse Compact.

Work fine for me
Except maybe
I did not find a way to center back (like the double click on the cube
the zoom in/out too fast

SpaceMouse wireless. It is strange. When I change the settings the button highlights normally. The function doesn’t change though.


Hmm, from the screenshot it looks like you are changing the application-specific setup for Firefox. The 3Dconnexion driver can be a little bit confusing in regards to this, but I found that if you start Shapr3D, select that window and then switch over to the 3Dconnexion settings window it allows you to change settings for that app. It should show the name and icon of Shapr3D in the upper left hand corner of this settings window.

I gave that a try. It works when I highlight the 3D connexion viewer. Still not working for Shapr3D. It’s weird. Any other ideas?

So you did highlight Shapr3D before changing the settings, right? Like this:

After a lot of aggressive clicking back & forth, I could indeed get to a state when the settings did not get applied, but we couldn’t find a reliable way to reproduce it. What fixed it immediately for me is triggering a “Reset all settings”-- though beware, as it resets all settings, not just the ones for Shapr3D.

As it’s likely related to the driver and the app as well, we’ll work with 3Dconnexion on this. To help that process, could you please post your driver and SpaceMouse firmware versions?

@Macher, thanks for checking it out!

Button assignments are already working in internal dev builds, they’re going to be rolled out to everyone within a few weeks at most.

The issues with the Wireless SpaceMouse indeed sound bad. I’ll be honest: so far, we’ve only tested the operation with wired devices, and there might be things that work differently with wireless ones. We’ll check it ourselves now, but if anyone else has a wireless SpaceMouse devices, feedback about your experience is welcome. Also, it’d be great to get the exact software, firmware and model & serial numbers about your device would be great – all available in the About window I posted a screenshot about above.

We tried to reproduce the problem working together with 3Dconnexion, but we couldn’t do it so far.

Could you test one more thing for us? We know that there’s a gap in operation when you minimize the app and bring it back again – it takes some time for the app to build up the connection with the SpaceMouse again. We are working on making that time much shorter, but in the meanwhile, could you please try to check if the problems you are encountering are happening when you’re minimizing and un-minimizing the app? They should not be happening if you simply alt+tab away, only when you minimise the app and then bring it back from the taskbar.

I have the exact same Spacemouse and firmware version as Macher. I too am having the same problems, It does not occur when minimizing, but during active usage.

Thanks for the report. We’ve ordered a device like that to check what’s going on. One final thing that might be useful is your exact Windows version, from the “About your PC” dialog.

Edition Windows 11 Home
Version 22H2
Installed on ‎10/‎5/‎2022
OS build 22621.521
Experience Windows Feature Experience Pack 1000.22634.1000.0

Thanks. We’ll try to reproduce & debug the issue and let you know.

Hi! We’re working on a fix for this, but until it’s available I migh have a workaround for this. If my theory is correct you should have two config files for Shapr3D in "c:\Users<YOUR_USER>\AppData\Roaming\3Dconnexion\3DxWare\Cfg": Shapr3D-KMJ.xml and Shapr3D.xml. The Shapr3D-KMJ.xml is generated by the SpaceMouse driver. This “new” (Shapr3D-KMJ.xml) configuration is shown on the UI while driver still sends data based on the “original” (Shapr3D.xml) config, that’s why the changes on the settings UI have no affect.
If you delete Shapr3D-KMJ.xml and close the apps (Shapr3D and the settings window) that should fix the issue.
To prevent this from happening (until we work out a fix) make sure that Shapr3D is actually getting the navigation events befor changing any settings.
Please let us know if this helped or not.