STL file measurements wrong when exporting from Shapr3D


When my brother try to 3D write using STL files created in Shapr3D they have all measurements in inches even though I used centimeters or millimeters when I designed. Does anyone have an idea what I am doing wrong an how I can get the measurements right?

Best regards, Niklas

Hi there!

STL does not contain any unit information. Only numbers. This means that if you export to STL, it does not matter what units you used. This is not specific to Shapr, this is how it works in every modeling tool. I suppose you are trying to import it to a slicer - you will have to scale the model properly. It is quite unfortunate that STL has become the standard for 3d printing and for other manufacturing tools, but this is how it works :frowning: Hopefully someone will come up with a much better file format soon.

Thank you, that was very good information!


Hi Istvan!

I’ve been wandering, just out of pure curiosity, does IGES contain unit information?

Many thanks,


In addition, I’d like to ask if I print with STEP, will it contain triangles in the empty spaces?

Of course, igs does contain size information, but STP is always preferred over IGS.

can you clarify a bit what do you mean by the second question?

When people showcase their 3D prints, if there are empty spaces, these are filled with triangles. But this is probably only with STL, which is a mesh format.

That’s not related to shapr or stl, but it is the result of the slicer apps, where you can control the infill of your objects.

The Statement is incorrect, this is not how it works in every other CAD program

No, it’s not. I strongly recommend using 3MF instead. STL is an obsolete file format. Also I recommend reading this help desk article:

“STL files contain no scale information, and the units are arbitrary.”

Sorry, but all my CAD and Hard Surface Program export STL’s at the scale i create them

Hi Richard, I believe they do, but STL files don’t contain unit information. There can be a million reasons why you get the same size between two different programs when you are exporting to STL, but it’s not the STL format. I strongly recommend ditching STL and using 3MF instead. Also please read the linked help desk article, it will explain how to export from Shapr3D to STL in order to get the right units.

I have never had to re-scale a STL in a slicer program, if i create a 1" cube and export it as an STL it imports into my slicer program as a 1" cube

Most likely it’s because the two software that you are using both handle STL’s unitless data in the same way. But there isn’t an industry standard for that unfortunately. This is something that you could experience between several different programs. It’s fortunate that the combinations you used so far are handling it the same way.

For 3D printing STL file are fine and will get the job done, if you’re doing something else other than that the suggested file formats may be the better option, I really wanted to subscribe to this program, but rescaling is not an option

No need to rescale.

This characteristic of STL files can be problematic when you handle slicers, for instance, if your model is created in inches and your slicer uses centimeters by default. To fix this, you can scale your model in the slicer or standardize the unit of measurement in your entire workflow. In Shapr3D, you can change your model’s unit of measurement to your slicer’s during the export process:

This is a 20MM cube from Shaper and a 20MM cube from Fusion

At this point I can only repeat myself unfortunately. Please check out the shared information above how to properly export STL files or event better: export 3MF instead.

I had the same problem with STLs from other Cad programs imported in Prusa slicer. If you didn’t change to mm before exporting you had to rescale. Change to mm before exporting and problem “accurately” solved.

What slicer are you using? Shapr’s exports are very accurate and reliable when you change to mm before export. You might try a different slicer.