Unable to Save to Google Drive from iPad Pro

For some reason I recently am no longer able to export to Google Drive from Shapr3D on my iPad Pro. It worked just fine for years but now I get “You Need To Authenticate Before Accessing This Item” when trying to save to Google Drive. I have looked up this error and it seems to have to do with iCloud. I have tried to turn iCloud Sync off and back on as suggested. I have verified I can access my Google Drive on this iPad. I have rebooted the iPad also as suggested. I have uninstalled and reinstalled Shapr3D as well. The only change is I recently changed from a 2TB iCloud account to a 200gb account. It’s like Shapr3D is not authorized to access Google Drive or something but I cannot find anywhere to change that. I am using the latest Shapr3D from the app store as of posting this. Currently on iOS 17.1.1 on an M1 iPad Pro.

Any help would be great!

I’ve just tried and it worked for me.

1 Like

Yeah I figured it would, it’s not a major Shapr3D issue. I am wondering if someone has run into this and has been able to fix it? It’s something to do with when I changed my iCloud account. What that has to do with saving to Google drive I have no idea but a search on how to fix this error in relation to other apps has to do with iCloud however I have already tried those other remedies and still nothing. Saving to Google Drive has worked for me for several years until I changed my iCloud drive account size then all of a sudden I get this error.

Unfortunately we have no control about what’s an allowed target to save, it’s totally up to iPadOS.

I completely realize that I just asked in case someone else has run into the same issue.

1 Like


i do have the issue, that i cannot open files from google drive. even if i make them offline available before trying to add to shapr3d.

I’ve also noticed that too. It seems that if you go a couple of folders deep it no longer recognizes them. If you save it in a higher folder (or whatever the correct terminology is) it works for me.