Why loft not working in this case?

I noticed it since loft was introduced.
Why can’t I use it on edge to edge sketches?

I think the loft function tries to create a body with the outer most parts of the sketch as boundaries. Imagine looking from ‘below’ the ground, through the horizontal sketch and towards the vertical one. Loft essentially tries to create a body from that “view”. And so, if you place the sketch close enough, you couldn’t ‘see’ or line up the boundary.

From a purely mathematical view, the projection between the orthogonal walls is zero over the entire space, so I might be wrong. Because this would mean you would need to offset the vertical sketch slightly too in order for the loft to work. But then again, it might be due to approximations that it actually works when you offset one of the walls

Also, I could be completely off!^^

1 Like

I see your point.

But it can be override in special case like this, to only creat a boundary on one side.
I can work around it as shown in the video, but it’d be easier if there were a solution to it.

Thanks @Einar :slightly_smiling_face:

1 Like

Hi Jack,

It is possible that something is covered in the workspace? The loft works flawlessly on simple sketches even if there is a body behind a sketch. I’d be happy to check the Shapr3D Design :slight_smile:

I tried like 10 times to do what you did here. It doesn’t work for me

Is it Jack’s workflow or mine that does not work?

Well, I found the error and I think it might be something you should look into. Do the sketch as you did, then click both faces. Then try to find the loft option, you won’t.

But if you go into tools and select loft, then you can loft between those faces.

Point being, the loft tool did work for perfectly aligned orthogonal faces, no matter the setup. But it doesn’t show up if you select the faces. It does show up if you do as Jack did, i.e. create a small gap between the faces. Strange thing

@KPeter_Shapr3D Wow how did you do that ?
What @Einar says is the bug I think.
It doesn’t work when you select both faces.

Indeed the tool is missing from the adaptive UI, thanks @Einar for spotting it. The issue occurs only if the two sketches have overlapping lines. If you move away one of them just a tiny bit, Loft is appears after selection.

@MrJack88 just what you saw. It is important to note that it was a clean workspace with no overlapping faces of other bodies, etc. I’m still here to check the file :slight_smile:

1 Like