3.7 beta is out on Testflight for Beta testers


#1

Hi everyone,

Yesterday we have released the 3.7 Beta. Here is a short list of the new features:

  • Primitives: Rectangle (Center, 2-, 3-point), Ellipse, Circle
  • New Sketching and Constraints Menu. Sketching Menu available under the Main Menu.
  • Constraints will only appear, when there is something to constrain.
  • New Spline (Fit point, Control point)
  • Undo (2 finger tap) - Redo (3 finger tap) gestures

Do you find the new features useful? Is there something that is not clear on how to use them. Let us know under this topic.


#2

Downloaded it and tried last night. The first quick feedback are as follows:
1- single-edge offset is missing which troubls much, pls do a quick recovery, it’s vital
2- appearance of the magic pen button after selecting it, is redundant
3- rather than a circle primitive it’s the triangle that needed since circle gesture is quite fine, easy and quick with pencil
4- after extrusion a surface the dimension will not disappear just like a tick!
(vid attached below)


#3

Hi Hamed,

thanks for the feedback. About the Offset, you can still get the single edge one from Tools/Offset - just not in the Sketch menu.


#4

We are going to add a polygon pen as well, where you can decide on how many sides should the shape has. You’ll be able to draw triangles with that.


#5

Thanks dear Daniel, you saved me a lot of time! But simply it’s more needed in the sketch list and you might consider that!
Furthermore, I didn’t understand the functionality of “hide badges“ button


#6

The new undo/redo gestures are quite handsome , thanks


#7

I sent messages to the Istvan email address in TestFlight but will repeat here.

The Rectangle tool based on 3 points does not seem to work. Tried everything, nothing happens.

For splines, was able to easily create closed sketches and move about. But the control points seem not to work. Tried everything, nothing happens.

The center point of a rectangle does not seem to snap to the grid. As in centering a rectangle about the origin.

Thanks for all your efforts on this new version.

Best,

Tommy


#8

Thanks @tommyn, your feedback is really useful.


#9

Some additional feedback…

I have a simple trapezoid. What does the interior white dot signify? Is it some type of area centroid?

It seems to have no value because it disappears if you go to the Movement tools and you can’t drag the sketch by dragging this point directly.

Moving forward I was able to “center” the sketch based on an X and Translating the center of the X to the origin. But note now, even more white dots…

I decided not to center on the X but rather on lines connecting the midpoints of the opposite sides. In this case the line midpoints are useful. And I used the Translate tool again, this time from the center of the crosshairs to the origin.

I see that the dot comes about from the Show sketch/face center option. But I don’t see any dot when selecting a face. Some clarification here would be appreciated.

Thanks,

Tommy


#10

Another possible bug report, unlike for @tommyn mine will not show the centroid of the region but when I draw the diagonal the new centroids will be shown. See vid below:


#11

New bug when editing rectangles.https://discourse-cdn-sjc2.com/standard17/uploads/shapr3d/original/2X/8/854a0ee01d33bab46ea0e72caa8b86a416164b8a.MP4


#12

If auto-constraints not ON, could be a feature.

Best,

Tommy


#13

Re the Spline tool, seeing some movement today. While working in a new model was able to modify the spline by dragging one of its points ( didn’t pay much attention but made mental note to investigate further.)

So I did a simple sketch in a new design. Was in Control Point mode. Et voila, the seesaw control line appeared upon selecting the control point and if an end point is selected, the spline shape can be adjusted. Nice!

So I deleted all and now in Fit Point mode, tried again. But the control point acted in the same manner.

So still a bit confused here…

Best,

Tommy


#14

Have noticed a long existing situation where the Groups window seems to hang. That is, the only way to + a new group is to close the window and reopen and try again.

Best,

Tommy


#15

Strange situation where I am mirroring two sets of chair legs.

I mirrored a back leg with no problem. But the front leg will not mirror across the construction plane. The plane can be selected but not in the mirror process.

Shapr file encl.

Best,

Tommy

P.S. A possible clue - there are 5 sketches where the 4 chair leg meets the chair. Looked all around for the mysterious 5th sketch, odd.

Chair.shapr (292 KB)


#16

While working with my chair, I had to zoom out to make sure that all parts of the chair were selected prior to a move/rotation. Did this for 2 chairs. On the first, I approached from the left and after a zoom out, it zoomed back in automatically every time I selected a chair stay (6 of these), very annoying. On the second, I approached from the right and this behavior did not occur.

Not clear why this happens?

Best,

Tommy


#17

While saving files out of Shapr, you see this dialog…

What, where to and how can I drag ‘n drop? And why would this make life easier?

Inquiring minds you know…

Best,

Tommy


#18

Hi Tommy - sometimes the gizmo/handlebar was not visible, and got lost. This was our first attempt to solve the problem - zooming out to the point, where it is visible.


#19

If you are multitasking on iOS, you can drag and drop files to an other app. It comes handy for .obj files which can be used in other apps.


#20

Most people just don’t know about the system wide dnd feature in iOS, but it’s very useful :slight_smile:
https://developer.apple.com/ios/drag-and-drop/