Big issue starting the app

Hi Shapr Team!

I came across a big problem today, hope you can help:
Opened a file to work on, nothing large, no imported files. After 2 minutes the workspace was there and I wondered what the problem is so I wanted to clean it from some drawings. The app crashed when I tried to delete the first part.
After that, every new start of the app starts in the corrupted file. So I can’t work in the app anymore.

  • Is there a chance to start the app without starting the last file worked on automatically?
  • when I have to reinstall the app, will my other workspaces be gone? (Would cost me the last two weeks of work)

Thank you very much for help in advance!

Hi Gerd - Thanks for the Great explanation. What if you “kill” the app from the control center. Usually it helps me.

Nonetheless, we are Award of this problem, and we have a couple of solutions to solve it, one of which we will implenent shortly.

@gms that’s a bug - Shapr should not load automatically the last workspace if it failed to load it the last time. We will fix it ASAP.

Until then the workaround is to connect your iPad to a mac or PC, and using iTunes, remove the corrupted workspace.

Thanks you for your fast response!
Great customer service!!!

Sorry, me again.
I see the folder workspace in ITunes under „Shapr3D documents „ but can’t open it to separate the corrupted file.
How am I able to fix this?

Hi, you can download the whole workspaces folder then find the faulty workspace by looking at the thumbnail pic in each folder.

Thats what I did. But them I am struggling because I am

  • not able to delete the workspace folder with the corrupted file or just the corrupted file via ITunes
  • only able to upload files, not folders

So I see no chance to replace the workspace folder with the corrupted file in it.

Any more thoughts? :sweat_smile:

Are you on windows or mac? I can upload folders from the mac without any issues (either by dragging or adding via the add button). If you’re on windows, i’ll have to investigate further :slight_smile:

Unfortunately no drag n drop in windows, can’t delete the old workspace folder and am not able to drag the healthy files back to the empty workspace folder now that I reinstalled Shapr3D

Oh. If you reinstalled Shapr then it’s easier now to just import those workspaces through the Files app/iCloud one by one.

You mean the workspace files? When I try to import via app I can see them in my Dropbox but can’t pic them to import.

Try adding a .shapr extension to the workspace files

Seems to like the file now but hanging endlessly „Waiting for download“ now.
Don’t know what that is as my other work in Dropbox is without issues so it can’t be the internet connection. I’ll try later again and keep you informed

Hmm maybe try it from the Files app (linked to Dropbox)

Ok I found a workaround:
Rename workspace file to „.shapr“
Open Dropbox app
Choose file and export
Choose „open in“ from the menu
Choose Shapr3D

Happy to have my work back :sweat_smile::+1:t3: