Bugs in Shapr3D 3.0.3, Transform tool, performance issues


Hello guys, just installed the most recent update and Transform tool became incredibly buggy, also old scene stopped loading.

  1. On very simple new scenes with 1-2 surfaces it works quite alright but on the old (pre-3.0.3) scenes with 10-15 surfaces it’s very very slow, even selection of the object can take up to 5 seconds. Movements of the objects can take up to 10-15 seconds.

  2. For curves in the old scenes the Transform/Move stopped working completely. I can select a shape, scale it but when I start to move it only moves the reference point, after the move curve either disappears or stays at the same place. I tried to restart iPad, open/close software, quit other apps - nothing helps. I’m on iPad Pro 2017. Here’s the brief video of the problem. You can also see how slow it is, the whole scene is just the object you see:
    I selected the curve on the bottom, you see how it disappears after a simple move.

  3. Also as complexity of the scene increases it greatly reduces loading speed. I have quite a simple scene - quite simple for any desktop 3D software (it’s 8 copies of the object you see on the video) - and it takes 3 minutes to load!

Are you aware of these bugs?

Thank you!


Hi. Thanks for the report, we will look into it. The video helps a lot :slight_smile:

Would you be able to send the workspace as well?


Not to pile on, nevertheless — within the transform tool, if you are not superhumanly careful, you can deselect, or even lose hundreds of objects that you selected (which by the way takes an extreme amount of time.) It appears the Apple Pencil, was not able to efficiently find or recognize the tool, amongst the geometry.

Also, the arrow/rotate/scale tool(s) apparently needs to be very isolated, or again, you lose the selection of virtually hundreds of tiny objects.

Lastly, I am also noticing with the increased complexity, even if you create the entire model in the app (without importing anything), it becomes increasingly sluggish, increasingly difficult to manipulate, and precipitates the need to move to the desktop.

Competitors are not running into the same issues in the same areas.


Can you share a workspace that you have issues with? Please send it to istvan@shapr3d.com, it would help a lot.


The other issue I faced is that exporting the same model you see on the video will export it with flipped normals using export function on the iPad to file. Surprisingly there was no way to tell it after export. It looked good.
And this is random. Sometimes it’s flipped sometimes it’s not. So when I got it into the bigger scene and tried to print it out on the 3d printer I got all sorts of errors, the model wasn’t printed, it was melting in the middle. Meshmixer reported issues with wall thickness but from what I measured there weren’t any. So it appears to be the problem with manifold. And needed to fix it manually.

Unfortunately I switched to other 3D software, quite swamped with work right now. I’ll try to send you scene when I have time next time. Thank you!


Sorry, seems the problem with manifold wasn’t caused by normals, rather the cause was in the holes. There were some holes between different surfaces inside the object after Fillet Edge tool. The surface wasn’t closed. It doesn’t show up on the mesh or in 3D software, but it causes the model to melt while printing.
In any case Meshmixer showed it like invalid mesh with thin walls.


Hi - would you be able to send the workspace to support@shapr3d.com? Would love to understand what the problem could be.