Cannot import STEP file

Hi,

I’m simply uploading STEP files from McMaster (as per the tutorials) and gives me import errors.

https://www.mcmaster.com/90294A633/ is the file I am trying to import, and attached is what get when I try to import.

Any help will be appreciated.

Thanks

Hi @shahmirj Welcome to the forum.

Please can you send the already downloaded STEP file to support@shapr3d.com? We will then further investigate the issue.

Meanwhile is it possible that you can also download the file from McMaster in IGES format and let’s see if the same happens for the IGES file.

I send the file over, also 3D-IGES had the same issue.

Some more information, the app version I am using is: 3.56.1 (x) (n)

Let me know if you want x or n numbers above as I am not sure they are private to me.

Hi @shahmirj, I actually downloaded the file from McMaster and I could import it as shown in the attached screenshot.
I re-exported it from the app in STEP format and here’s the exported file, please try this as well: https://share.getcloudapp.com/8Lungkw6

I see that you are quite zoomed into the design and this might be the issue. Please double-tap on the 3d cube using a finger to reset the view and then try importing the file while on the default 3d view.
Give this a try and let’s see if the issue persists.

The file you sent (https://share.getcloudapp.com/8Lungkw6) seems to import fine, thanks for this but this is annoying as I can’t ask you everytime I need to import :smiley:

I was at 50mm and your screenshot was at 1mm, but I tried doing all sorts:

  • Zooming out, then import
  • Zooming in, then import
  • Pressing the Cube (Top-Right), then import

None works, apart from the file you sent.

So I am not sure where the issue is, could it be to do with my Shapr3D install?

Figured it out, and this is subtle.

I was using Chrome, when I used Safari (I assume this is what you used @Victor_Shapr3D) it all worked fine. For the sake of my sanity what happens if you download it from Chrome.

Hi, okay that’s interesting, it’s great that we are getting some headway with this.

I actually downloaded the file from the website initially using Chrome :grinning:

I would think that maybe an installed Chrome plugin is somehow getting the file corrupt.
Please turn off Adblocker if you have any installed and then try again or maybe you can try re-installing Chrome.
A quick way to test to see if it’s plug-in or browser-related will be trying while on incognito mode( plug-ins are not active).

I am using chrome on iOS, without any extensions. So when you download a file from chrome maybe the underlying unix permissions are strange. Which I can’t test and the error message does not help.

It will be worth adding that as a bug report. For the moment, I am happy for the safari workaround. :smiley:

Okay, I see. I guess we can agree that if the file is not corrupt and downloads fine it works great in the app. This way it doesn’t seem like a bug particular to Shapr3d.
It could be browser or device-related, I’m not sure.

Well it is a bug in a sense that I am not sure weather the issue is with:

  • Chrome download,
  • iOS unix filesystem (when downloading from chrome),
  • or Shapr3D falling over because of the download was based of chrome.

So it’s worth investigating rather than closing, as it may be with Shapr3D (still unknown). And I would prefer to use Chrome rather than using Safari just for Shapr3D, especially when I am using the native (without extension) Chrome.

1 Like