Difficulty exchanging files with solidworks


I am working together with someone who can only use solidworks to edit files. I am trying to use his .STEP files however I am not able to open them using the ipad file manager. Shapr simply does not appear in the list of apps I can choose from to open the file with. Any clue on what I could do different to solve this? Files are mostly used to 3D print

Hi, thanks for reporting this. We have received similar feedback and we are working on a fix for the issue.

Please try either of the import options shown below depending on how you were already trying to import the file.

Kindly give these a try and let me know if it works.

1 Like

I tried both these methods but no succes.
The first method doesn’t work because the Shapr app does not appear in the list of possible apps.
The second method doesn’t work because no matter what file extension I use, the file is not “clickable” when I try to import it. The name appears in grey letters, not clickable black. I am only able to load images

We are looking at this issue - and I’ll write a longer explanation on the subject later today. What we see currently, is that deleting apps that can read STEP can solve the issue - it might be an iPadOS bug.

Also as you are trying to import from SOLIDWORKS, you should try the X_T format (fileformat of Parasolid, the kernel both SW and we are running on). That format doesn’t have this issue.


Right now I cannot import any file type other than images. I tried all the possible listed supported file types but they are all unclickable when I try to select them from various locations. Any fix?

Do you import from the app, or outside of the app? Where do you import from?

Will look at the issue as soon as we understand the situation more.