Can't import files (STP, STEP, IGES)


I have tried importing files created in rhino to shapr (STP and other supported format) but nothing seem to work. I tried opening files I was able to open before and even those can’t open. This seem to be happening since the new update. Am I doing anything wrong?
I have attached two images to show what I am talking about.
I have also tried to email myself the file but that option doesn’t work as well.



Really weird, the problem is that the cloud access SDK on iOS not very reliable… I will take a look anyway, we are going to release a new version soon, and if I find something we will fix it. Until then, you may want to try to rename the file to have .step extension or .STP or .STEP, that might help… Sorry for the inconvenience.


That’s fine. Thank you for the quick reply. I am looking forward for the update and hope you will be able to find the source of the problem :slight_smile:


Hi, unfortunately we still don’t know what causes the issue with Google Drive. In the meantime, as Istvan said, Dropbox and iCloud should work fine as long as the files have the correct extensions!

We’ll get back to you as soon as we fix the problem with Drive.



Thank for the reply and assistance to both of you (Istavan and Tamas). I did try the changing the extension on Dropbox and everything seem to be working using that method :slight_smile:


Istvan, I have tried to open stp from maxonmotors previously succesful however not since downloading your update the other day.

The round icon is just sitting there greyed out and nothing is going on.



Hi- How long have you waited for it to load? Would you be able to share the file?


Previously those stp’s downloaded from Maxon(electric motors) opened fine, now I wait for minutes with only a round icon not indicating progress. I.e., even those older downloads which opened fine before.

New downloads do not come through at all either.

I have not icloud enabled as I do understand all this happens in a native environment. Those zip’s containing the stp’s I open with Izip.


I see. would you be able to send one of those files through:


Just sent you the zip file containing, downloaded from Maxon.

File structure b.s. on Ipad is just driving me nuts, thinking just staying desktop browser. Used Izip, but disabled that app now and sent from Fileapp now. ”Open in …” does not work flawlessly with all apps on these freaking devices. No, I do not use iCloud! Most problems for me have progressed with each Ios update, now using 11.2


Somebow, the snapshot ended up being a videoclip and turned out black when trying here to upload it.

I’m loosing my patience more and more with these app product devices and unfortunately I must say that Onshape is a much more interesting offer, regardless of their product also having these app device issues right left and center.


Succesfully opened another different stp download from Maxon.


Tried other downloads from Maxon and the latest one totally frooze your app.

After all Maxon makes the motors for the Mars rover so I have a problem thinking that they could not assemble a functioning stp file. :))


Ok, I’ll tell you what. I will uninstall Shapr3d and if you’ld be interested in having me return just e-mail me.


Hi - I got the emails - I’m looking at the files now. Sorry about wait


Hi- here is a video with uploading the file. It takes like 40secs but it does the job.


I’ve used a newer release (still in testing), 3.0.1.

With the 3.0 (currently in the App Store), I wasn’t able to import it. I’m sending the model in shapr. file in email. So you don’t have to wait for the new release and start working on it.

I can also send you a beta for 3.0.1.


Thanks for the video, however I have of course tried different files in samme manner unsuccesfully.Before I did go updating there was no problem with these files from Maxon.The timing sequence icon just stays ghosted w/out the blue progress loop, your video clip showing progress within 15-20 seconds on the contrary.I presume you being correct about the 3.01 and will reinstall after you give me a go ahead wink.

Skickat från Yahoo Mail för iPad

December 8 |
Hi- here is a video with uploading the file. It takes like 40secs but it does the job.

Visit Topic or reply to this email to respond.

In Reply To

December 8 |

Ok, I’ll tell you what. I will uninstall Shapr3d and if you’ld be interested in having me return just e-mail me.
Visit Topic or reply to this email to respond.

To unsubscribe from these emails, click here.


Back after reinstalling your app updated, .01.
Thanks for the tremendous amount of willingness to solve issues!


Don’t really need to toot the horn too loud but keep up the impressive devotion and you’ll have the most user friendly and speedy modeller out there for instant idea development.
In additon as mentioned, any support level of your kind needs recognition.

Have a merry christmas now and thanks for the “christmas present”! :wink: