Cant subtract anymore

I have an finished STL File, witch i want to edit. when i import that, i have no meshes, so i cant just edit it, i have to improvise a bit (or you teach me something i didnt knew).
So basicly its just letters in a specific font. a few mm high, rounded edge. nothing so special, expect the font i need. so redoing it is way more work to do
my aim is, to extrude it more and with an angle point at the bottom, so the letters are facing like 40 degrees in a bow.
Well i simply just used Pattern with circular. 120 so the bow is as round as possible.
then i wanted to cut the bottom, so its one flat part.
on 4 of 5 letters that was no problem. just marked them in subtract as +, and an flat object on bottom as - . Worked mostly very well, all flat no. BUT at one letter i stuck now. im doing it the same way as before. i cant accept the changes, the hook button wont show up!
so i just marked a few parts with +, and then again the flat object as -, worked. so i repeated, and now i have a few objects left to make flat, but it wont flat them, hook button dont apears again! :frowning: no error visible…
i also just watched in a few similar topics. mostly its like “be sure that object is closed…”… it have to be closed, because like 100 copys of exactly the same part i was able to substract… so i coulndt imagine why it cant boolean it.

OS: Windows 11
Version Shapr: newest from Windows Store aka 5.430.5508.0
other stuff:
RTX 3080, Ryzen 5 x5700, …

Could you maybe record a short video of the problem? I am not sure I 100% understand what seems to be the issue based on the description.

Also, if possible, it’d be great if you could share your design as a .shapr file here or with our support team.

at the moment i just have a picture, but i think that should show the problem. as you can see, there are way more objects (letter R) that arent marked. Thats because they already substracted from the bottom part. so they worked well. But the parts now marked, wont work. As you can see on the left side, the “Go” Button is missing.
i cant upload it as shapr in here, because i get the Error “Sorry, new users can not upload attachments.”

looks like just that few objects have a problem. when i try to unify them, i get the boolean operation error -.- but wtf… the others hadnt have that problem! and its literally a copy of them, witch hadnt a problem

Intersecting that many, barely differing bodies, especially imported meshes is inevitably going to put the geometric kernel under a lot of stress and it’ll be hard to figure out what went wrong – and the end result will be very low quality.

Instead of trying to make that work, I’d rather try to reverse-engineer the letter’s shape and create a sketch from it. Either by trying to find a font that resembles it more closely (it does not seem to be that complicated), or by placing a sketch plane on top of it and recreate the shape using lines and splines.

After that, you could use the sweep tool for this job.

Or, even easier, you could even just simply rotate the face (though that’d create a different shape):

1 Like

thanks. i thought it would end like that. makes sense. shapr3D has to calculate so many different objects. maybe its just an over kill and on some point after doing substract like 500 objects, its overheated :smiley:
the only way would be reverse engeneering by pathing it from the bottom. Because its the “Cupra” letters from the car brand Cupra. Seat and Cupra have houseown fonts they use, so no free available. And redrawing it i would lose details again, its an already redrawn (or 3D Scanned idk).

But: i just redone the whole thing again. But this time i setted the anchor for the pattern (circular) on a point that isnt crossing one of the letters. With this, i dont even get that parts i tried to substract away.
in the screenshot, i marked the origin letter. also the anchor point for patterns is visible. the part is now flat.

Well, you are certainly pushing the limits of what Shapr3D can do with mesh imports – we’ve not really designed it for that :slight_smile:

May I suggest an alternative path? Wikipedia has a nice vectorgraphical Cupra logo in SVG format. While we don’t support SVG imports directly yet, there are many SVG → DXF converters out there, including free online ones.. You could convert that SVG to a DXF, import it to Shapr3D, and then you’d have a nice, detailed sketch with the correct font that you could properly extrude, sweep & manipulate.

Using that approach I believe could get quite close to what I believe you wanted to achieve:

The only problem I see is that the converted DXF drawing is not entirely smooth (even though the original SVG is), so you either need to do some post processing by adding fillets, or try other converters or settings that result in smoother shapes.

1 Like