Corrupted Files?

So Ive been using the app on an Ipad Pro and this seems to be a persistant problem.

This is my best guess. Problem seems to be happening after I collide 2 seperate structures then leave app, but only sometimes. When I come back I cannot edit a surface like before because it creates a weird thing. See pic.

Yes, unfortunately it happens sometimes for me too.

90500FBF-34D6-475F-A1A0-53DA0F389930

Sorry wanted to post a pic but they blocked my account since im new. I did move the object with transform but the issue persisted. Not really sure how to correct but dont want to lose this model.

Will post pic as soon as they open my account.

Thank you for your response!

https://drive.google.com/file/d/1xutBuVgyqJ8ZFXrv2JG8O9tKETQ0wRQu/view?usp=drivesdk

It opens, but the issue is that when trying to sketch and make a shape on the lid this is what happens. Ill try to make a vid.

https://drive.google.com/open?id=1FnTAg_lr7-Tu6D9ptj4kXWIxpjlrTGy8

What happened right before this is that i deleted the grip function because it was extruded, making it bad for printing. I wanted to intrude instead. But before i finished the project i left the app. When i got back there i couldnt undo.

I think problem solved. On another model while in app i colored it and had same result. Undid color=no issue :0 so probably some code that needs fixing.

Now I am, lol. Was previous version. However im about to go sleep so ill probably see if it repeats tomorrow. Thanks alot for spending your time to help me try to fix this. Much appreciated!

Heres what I was working on; https://www.thingiverse.com/thing:3310955