Export fails, then app lags badly

While trying to export a design in .shapr format from my iPad Pro, I chose the option “share with” to airdrop to my iMac.

The “share with” window comes up blank, no option to share to anything.

Immediately after closing the sharing window, the app lags BADLY.

Closing and restarting the app fixes the lag, but it still won’t allow me to airdrop. The same problem with lag returns after attempting.

I also tried to export with another design, same problem.

However, I was able to “save to files”.

I tried restarting the iPad with no luck, and verified I am using the latest app version.

If I locked the screen with the sharing window open (blank), and unlocked the iPad, the app crashes.

I did forward on the crash report.

I don’t recall this happening since updating to the latest version, exports have been successful via airdrop or messages.

Hi!

Please check the last post in this topic: Am I blocked? 🥺 - #4 by MrJack88

Sadly it’s a known OS bug, it’s really strange that Apple still didn’t fix it. Some apps / their combination somehow messes up the Share feature.

Thanks @Laci_Shapr3D

So the “forum in the app” issue stems from the same issue that’s not allowing me to airdrop to my iMac?

I haven’t had an issue before, as in the past few days.

edit: as in airdrop from shapr to my iMac.

Not necessarily, but we see the Share getting messed up from time to time. It’s relatively rare, but a user reports it once every few months.

I can suggest 2 workarounds:
Either drag’n’drop the created file to Files or iCloud, or simply save to Files, then Share/Airdrop from there (though sometimes that share can also break…).

Also, a tipp from one of our colleage:
“For me on iOS 14.x sometimes the os level share menu does weird stuff, like some apps to share disappearing. Besides reboot the workaround I found is to change the system language of the os to something and back.”

1 Like

Thanks @Laci_Shapr3D I’ll give those suggestions a shot.
What seems odd though is that after the app experiences a break in sharing, it begins to lag like it’s 2003. And only Shapr lags, until restarting the app.