Fixing STEP files that have an error?

So, I imported the step file that Steam has released for the Steam Deck (Steam Deck / Hardware · GitLab), and trying to do any boolean operations on it fails with an error.

Importing the STEP file into the HBPM beta shows the imported object’s name in red, which I understand means there was an error of some kind, and that the ability to fix those errors in Shapr3D is being worked on, but is not yet in place. I’m assuming whatever error it’s triggering is the cause of my boolean issues.

Is there a way to identify/fix this kind of error in other tools? I’ve imported the .step into FreeCAD and the re-exported it, to no avail.

Does anyone have other suggestions?

Can you export from Freecad in another file format?

I tried IGES, but it came into Shapr3D … wrong. Pieces kind of all over the place. Not sure what the deal was there. I didn’t see any other 3D CAD formats that Shapr can import.

That happens frequently for me when exporting from Fusion 360 as STEP.