How to modify 2 parts to an imported object?

Pictured is a steel hairpin leg (furniture purposes). I need to adjust the canting of the “L” base plate in relation to the 3-rod legs & their respective angles. Pretty simple. So, I’m able to select the parts of the base plate but nothing happens when I initiate any actions upon the object when I move/scale, rotate, etc… What’s the deal?IMG_A027A9662953-1

PNG PNG PNG

https://aws1.discourse-cdn.com/business7/uploads/shapr3d/original/2X/a/a54f246537c63545408634f91048c1cee54c42a1.mov

How many ‘parts’ does the base plate have? If more that one, try to Union them together and try again. It does not look like the Transformation point is attaching to the base plate.

Best,

Tommy

Not that many, just the sides of the body & some chamfers. Union for some reason is worthless. It selects the legs and the baseplate as a whole. I need the base plate independent of the legs. Because I need to modify the relation of the two. Union won’t allow it.

Using uMake to make these adjustments. Giving up on Shapr3d everyday I play with it. Clean UI, but very inept flexibility so far…

food for thought: designers need flexibility to modify & tweak a world of millions of pre-existing objects - off the shelf, already existing and available to plug into an ideation. Simple tasks like this require quick precise flexibility without the need to create lengthy forum hash-out frustrations. There’s more flexibility in competing products at 1/2 the subscription price. …Although I am rooting for Shapr3D; the clean UI has a lot of potential…

Different app, but same iPad. Keep in mind, I’m 1.5 hrs into auditing/learning uMake, and I can perform this function at a very fundamental skill level.

FLEXIBILTY for the creative professional. Not inside baseball. Not redrawing the already-existing either.

In Shapr3D, I spent 3 hrs trying this procedure and just gave up. And I won’t be back until this kind of flexibility is addressed head-on, with the utmost ease.

Gotta improve the process to translate & tweak our ideas. Thanks

PNG

Try to slide the “copy” before you move it , usually help for me in theese case…
A

That didn’t work. Nothing worked. The one thing that has worked: use a different app

Did you unifiy the L with 3 legs?! I mean did you make a new body out of L or it’s simply a part of the same body together with 3 legs?! If the latter is true then you’ll not be able to do that and it’s pretty logical awesome.

Nothing has been unified in that leg. The same object/file was imported into uMake and the intended adjustment was performed in seconds.

Logically, I’ll move forward toward the path of least resistance. Saving money in the process by using apps that work.

Frustrated…Meh. I’ll check back in 6 months, maybe this stuff will be addressed

uMake is doing wrongly. It’s enough for you to consider that when you have a single object, you cannot rotate one of its parts without ruining it; you have a chair and you want to rotate one part, is it normal or you must first detach one part from the rest?!?! uMake by nature, explodes every object into parts and you’ll be forced to unify many parts at the end for objects which have many parts(if you aim to export the whole object)
Just for your considerations; uMake is a disaster for one who is seeking to do precise work. I’ve been using both apps since 2016, uMake’s STL files are not printable with numerous issues, it didn’t have dimensioning for quite a time and after adding the feature it’s not handy at all, and many other issues I had, led me to abandon it. The only preference of uMake over Shapr3D is its viewer which is better than Shapr3D.
After all, that’s definitely your choice friend!

Best

Doing wrongly? The iPad pro app of the year? huh…

Consider that many of us don’t need or use a plastic printer.

Exactly. It’s my choice. I can’t even pan from 2D to 3D smoothly on Shapr, it glitches and the viewer jumps to 30 feet out! Nothing precise here as well, can barely get by the simplest of operations to run optimally on simple drawings. Better to wait until the app can prove itself …with, like you claim, precision. Until that day, drawing elsewhere. Guess I’ll drop in and extrude something for free every other week like a stress ball and then back to a workflow that’s legit

I feel your pain, and I am truly sorry about the bugs, that are indeed annoying. However, we are always doing our best to fix these issues as quickly as possible, and 95% of the reported bugs are fixed in two weeks. These bugs are not exceptions as well, and with the next release they will be fixed. Sorry for the inconvenience.

2 Likes

looking forward to see what’s in that next release!

Don’t rely on those labels “app of the year”, “editors choice “, etc, furthermore, that label is for its very first years of birth. I said Shapr3D is not a good viewer also, but is as much precise as traditional CAD softwares like CATIA, Solidworks,…are
Anyways, I wish you best of luck, go forth and conquer!

…not if you can’t modify pre-existing objects easily. It’s worthless if it doesn’t communicate with the rest of the gazillion objects in the world. FLEXIBILITY. Otherwise why use an iPad… Just draw direct into a flagship CAD

I’ve been importing from CATIA, Freeform plus, FreeCad and Ansys into Shapr3D with no issues to date in STEP format for about 3 years. When you import an object (which has a number of parts in another software), in form of a unity, you’ll expect to have it as a whole not with its parts singled. Even most of CAD systems have the option to “export every part as a single object” or “export as a whole”. So I am not going to count that behavior of Shapr3D as a false but an approach (which I think is a true one, too).
Furthermore, I prefer to drink my cup of cappuccino and wish you best with your uMake buddy.

Have fun

I don’t care if you haven’t had issues. I have had issues, I went to forum to comment on it and show the process I’m trying to do. Your replies haven’t help and now the’ve turned toward downright hatred to an app, a process, who knows. Sounds like you have an axe to grind.

If you have something constructive to contribute, then do so. If effective & knowledgeable-enough as you sound here, it might even me over to continue using the app. But an aggressive response doesn’t help anyone. Avoid the sarcastic swipes at people. Your comments will get flagged if you’re looking to troll and pick a fight. So cheers, buddy.

I think this debate makes little sense. :slight_smile: the bugs will be fixed, and I hope Jared will have a much better experience next time :slight_smile:

2 Likes

I really don’t understand what you mean by aggressive! Was that “wish you best of luck” aggressive?! We’re not fighting here, friend
No problem, I tried to clarify about your issues; you had 2 problems:
First the viewer of Shapr3D, which I agreed with you and said it has not a good viewer compared to uMake
2nd: you would import a body and tried to rotate part of it, you were not successful in Shapr3D but in uMake; I clarified; the Shapr3D approach is true not the uMake’s, if you wanted to have each part of that body as a single you had to export from the software you were working on, with one option on>>export object with its parts not as a whole (I can show you the option if you want)

don’t worry about it; furthermore, sounds like you’re too busy drinking your cappuccino to walk someone through a solution to a problem. Best of luck little buddy