Is there any update to this insane performance degradation

I want to say this as politely as possible, But I’m genuinely going crazy with this new update, man I don’t care about the workflow changes or nothing but the performance degradation is too much for me to work normally for long periods of time now.

I have a video attached down below

This is after I let my iPad cool down. It was even worse before. It takes seconds for things to register when I use my pencil. I’m getting very tired of it. Sketching should not be this slow at all, it is also not just sketching

I’m literally losing battery while charging, I’ve never ever seen this before

I also didn’t even know this message existed on an iPad

Is there absolutely no way for me to roll back? I am very desperate at this point, it takes me minutes to load and upload my files now compared to the seconds it used to take, and I noticed things don’t run in the background anymore so I literally have to sit there and wait for things to finish


Export your file to X _T format then reimport to a new file.
If you have sketches you want to keep export them separately to dxf and reimport.

You will see big improvement.

Currently this is the only workaround. If it doesn’t work then the only option is to send the file to shapr directly and see what they have to say.

I’m sorry to hear that you are experiencing performance degradation. Can you confidentially share the design in which this happens?

How can I do that? Can I send you a DM with a link or something?

Sure, that works.

I know, but unfortunately, I have a lot of materials inside of the project and I want that to carryover as well

1 Like

Thank you, we’ve managed to reproduce the issue. It’s unfortunately the same problem as with many other large (multi-thousand parts) assemblies. We are working on a fix already.

That is good to hear, But I think it would be helpful to mention that if you open that project on a PC/Mac then back on the iPad, the iPad will crash while loading up the file I think this is because of the “back up auto generated” folder Basically doubles the body amount.

And while typing this

For some reason shapr3d Just decided to delete and Randomly reposition a bunch of Bodies out of nowhere, I’m not sure why, All I did was Load back up the file on my Computer after shapr3d crashed on my iPad a couple times. Thank God I have the back up, I just sent you. This happened on the windows version

Can you please share your device specs with us in a support ticket? Thanks in advance.