Latest design can't be opened all of the sudden

I have a fairly large project that I was almost finished with. Everything was fine yesterday, but today I go to open it on my Mac and I just see a Circle with a line through it over the thumbnail and it will not open.

I tried exporting as a .shapr and re-importing it and it says it can’t be imported because it’s damaged.

I also tried opening it on my iPad, which initially worked until it forced me to sync changes, now that doesn’t open either.

Last ditch effort I install the Windows version on my gaming PC thinking the extra resources might help. Nope, same issue except I get an error that says “Your source file couldn’t be opened because it’s damaged”.

I submitted a ticket already, but wasn’t logged in when I did it so I have no idea if it’s good or not. But this is really really bad. The project is insanely important, I have been working on it for over a month, and I was almost finished.

Shapr3D Version: 5.590.0 (6756)

Mac Specs:
macOS Sonoma 14.4.1
Intel 2.6GHz Quad Core i7
AMD Radeon Pro W5700

9th Gen
iPadOS 17.4.1

Windows PC:
Windows 11 23H2
AMD Ryzen 5 2600 (6 core 12 thread)
Nvidia RTX 2070

Contact Shapr3D support. They may be able to recover the contents for you.

I have, Im really hoping they can recover the data for me. In the meantime I wanted to see if the community had any advice.