Major Visualization Error - MacOS Intel i7

I’ve been working with a product design today and when putting it through the visualiser it worked fine for a while and then started giving me some crazy output as shown in attached image. I figured some error was just playing up so I gave it a restart. Worked for a bit, then started up again, worse than before. Decided maybe my package had corrupted so deleted app and redownloaded from App Store. Same issue.

Changing environment just makes different versions of weird:

Reverting everything to default materials doesn’t resolve issue.

Issue is also not with file, this is happening across multiple files.

Product is fine in Modelling mode as shown in screenshot. Issue is with visualization.

Definitely a program issue that is shared as when I create a brand new file in a new folder and visualise without anything built I see remnants of previous craziness show up on the screen from the initial product.

MacOS Specs

Help would be greatly appreciated.

Seems to be set off when I select the materials further down the list or tried to change the colour and then rotate the product to view from a different angle it just started going crazy on me. Also interested to hear if anyone else is running into this issue.



Have almost the same MacBook Pro but 15-inch (also with radeon graphic card, but I can disable it) no such issues ever seen.

I can run your model if you interested in such an experiment.

Yeah let’s give it a go, it won’t let me upload cause I’m a new user but here’s a drive link to the .iges file for the wallet design. Men’s Metal Wallet.iges - Google Drive

Mac Book Pro i7 16GB RAM (2019)

Mac mini M2 Pro 16GB RAM (2023)

iPad 12.9 Pro (2022)

1 Like


Strange though … any ideas on what might be the problem? Is my graphics card possibly the issue? I note that you have a Radeon on your MacBook, while mine’s an Intel Iris

Any recent updates to the Radeon card? Sound drivers? both can cause vid glitches on intel boards.

Looks like a borked driver to me. Hardware rendering on?

I turned it off for that test.

1 Like

I’m running the Intel card, not sure on how to change / update / mess with sound drivers or update the card, just running stock from Apple.

Also re hardware rendering - the only setting I see in Shapr is this:

Have tried Low Medium and High with restarts between each, doesn’t seem to make any difference.