What happened to being able to import models from McMaster-Carr? I use to grab fasteners from there to put in models or to subtract for threads and nothing I try to download works now. It’s been a while since I’ve needed to so maybe this is an old problem now, but I just encountered it.

Hi Roger, are having issues downloading the object from McMaster-Carr, or you not able to import the downloaded object from the app?

If the issue is that you are not able to import a file into the app please send the file to
We will look into it and then get back to you as soon as possible.

Not sure what to send you. It doesn’t matter what file I open (existing or new) or what I grab from McMaster the result is all the same.

I see - one specific one, would be very useful. I’ll investigate the issue in the meantime

Also, please try importing it in STEP - hopefully that works better than IGES.

I just tried it. No issues.

I noted this happens when I dont use Safari on the IPAD.
I generally use chrome and found files saved from Chrome did not save correctly maybe.

Chrome was the problem. I never use Safari and for whatever reason I couldn’t load an IGES from Chrome any longer but it worked from Safari. Weird, but I’ll take it.