New version: 0.2.5

New features:

  • Scaling. Yay! The Move/Rotate tool is now Transform tool, use the new yellow handle to scale an object.
  • Splines are now created with control points instead of interpolation

Bug fixes:
-Camera states are now restored when loading a workspace
-Steve suggested to highlight the X/Y axis with colors. Done. If you like it, we will keep it.
-Pushing/pulling now snaps to values depending on the zoom level. Previously it was only snapping to 0.1, 0.2 etc. values, that could be percepted as performance fallback. Special thanks to Yazan for pointing this out.
-Fixed a bug that could cause rendering artefacts in some zoom levels
-We made further adjusments in the Pencil pressure calculations, also lowered the required pressure for sketching
-Now you can delete your sketches from faces
-Fixed a bug that prevented creating faces from closed curves. Thank you Andy for pointing this out.
-We turned off the stupid auto alignment feature in the sweep tool. Now you have to manually align the spine and the profile, but at least it will do what you expect :slight_smile:
-Fixed some crashes
-Opening a workspace can be cancelled
-Fixed an issue that caused flickering of the camera orientation feedback. Thanks Shawn for reporting the issue.

Coming up next:
-In-app tutorial
-Setting the center of rotation/scale
-Editing curves

The new version will be available in an hour.

Cool! Looking forward to give it a test drive later this weekend! Great job.

Sorry, it took a little longer, we had some issues with Testflight (as always), but you should have received the new version by now.

No problem. Installed it and gave it a try. So far so good. Was not able to scale, but will take a look at this this weekend.

What happened? Did the yellow box appear?

Yes but I am not able to grab it. I can use all the others without any problems. Did I miss something?

I am having same problem with scale. it worked a couple of times but very hard to grab the yellow box. When I did get it to grab I have no idea why it worked or what I did different.

BTW I like the X/Y axis with colors.

I’m having same problem with scale - got it to work once, but not since. Dragging on the little yellow box doesn’t seem to do anything

I’m sometimes able to scale an object. But the point to click on seems to be above and just to the left of the little yellow line and box. Can’t do this everytime, but by clicking around the yellow box I have been able to find the right spot - when I do, rescaling works well

OK - I have found that by tapping around the rescale icon, I can always find the right place to rescale an object. The rescale point always seems to be about 1 cm away from the yellow box - which direction it is in depends of what angle you are viewing it from. Hope this is helpful in sorting it out. Sweep function is working well - much easier to use and I like the control points on the spline.

Thanks for the information. Was able to scale something, but this isn’t really working the way it should. Clicking around to find the right spot isn’t okay.
I have taken this picture.

Sorry guys, we are going to release a hotfix for this today.

Thanks for letting us know.

Many thanks. Hope you guys get a weekend off work sometime!

Weekend? We don’t even know what that means :slightly_smiling:


The hotfix is out, sorry guys. We had some issues with Testflight yesterday, and mistakenly uploaded a wrong binary. We are really sorry.

Damn that was fast! Just installed the new version with the fix for scaling and it is working like a charm.
No more fiddling around. Thanks!

1 Like

Just tried it and it’s working great. Thanks for the overnight effort :grinning: - John

1 Like

Yep - rescale works perfectly - well done guys!

1 Like

Forgot to mention - really like the little yellow arrow when filleting or chamfering - speeds things up a lot. How about having a green arrow for a positive fillet and a red arrow for a negative chamfer (OK so I am getting really picky now!) Thanks anyway - great update. Andy

1 Like