New version: 0.2.8

New features:
-now you can edit curves! Select a curve on the grid or on the face with your Pencil to edit.
-tutorial videos
-semantics of sketching have completely changed, now wires are not trimmed automatically
-iCloud drive support for exporting
-ghosted rendering mode!
-tap on the top right corner to open the Camera menu. You can reset the camera and turn on ghosted rendering mode!
-.shapr file format support, now you can export/import your to the native file format of Shapr3D
-we added in-app purchase, but indeed until you are using the app from Testflight it will be free
-new logo thanks to coandco designcommunication team :slight_smile:

-lots of bugfixes in undo/redo
-for big zoom levels now the grid does not rescale, this gives a better feedback of the camera orientation, and prevents zooming out too far
-now workspace thumbnails have proper retina resolution
-fixed a bug in the offset tool that could make really weird things with circles
-fixed lots of bugs in the face sketching algorithm that sometimes resulted bad geometries
-now if you tap on an empty area with your Pencil the yellow annotations will disappear

The new build will be available in a few hours.


Double tapping on a face, or even the grid, doesn’t do anything.

I updated to New version 0.2.8 and now it wont open either from TestFlight or the icon. All I get is a blank screen and then goes back to home screen. Tried rebooting iPad still no good. :frowning:

Looking into this…

Did you use you finger?

Same thing with me - app keeps crashing before it opens

We are working on this, new build will be available in an hour.

We are terribly sorry guys, we fixed the issue, the problem was in the upgrade process. We changed the application bundle a lot in the last few days, and had to include some stupid update logic, that was not tested properly. For clean installs this issue is not present.

Ps.: this is why we should not upload new releases 4am :expressionless:


Is everything OK now?

Nothing to apologize for Istvan. It is an amazing program and very complex I imagine. Glad to help out by finding issues early.


Oops…I was using the pencil to double tap, not my finger. Works OK with my finger. Can/should it work with the pencil too?

The pencil is reserved for sketching, the fingers are for navigation/camera manipulation. At least this is the concept now :slight_smile:

All OK now. Opens fine and everything seems to be working again. Thanks… I feel whole again. :slight_smile:


Yes - working well - really like the ghost rendering

1 Like

How do you like the new icon?:slight_smile:

Yes - icon looking good and in-app tutorials are good too - not too long but very clear. Not sure about the low-res stl export option - it really is low resolution! Wonder if it would be better with a little less reduction in quality - I know it is a balance with file size? Andy

Tutorials are very good. If I was picky, I would point out that the one on splines selects “regular” before drawing a spline. I learned something on positioning a sketch on a face. Keep them coming as time permits.

1 Like

Yeah, well actually the “positioning on faces” was in the original youtube tutorials as well, but we were pretty sure most people missed it :slightly_smiling: I think it is one of the greatest features of Shapr.

Yes, I did remember seeing it after watching the tutorial. But reviewing quick tutorials now and then helps to jog the old brain a little!