Super slow and using just one core (Mac M1)

Can someone please try opening this? It’s a simple pulley design. A circle with a single tooth made by 4 lines, drawn on the edge and pattern copied to 160 teeth.
It takes several minutes to open/render that on my v1 ipad pro.

Little better on my Mac mini with M1 cpu. Here I can see in my iStat menu, that only one of the 8 cores are being used. And that one is maxed out, so it’s not like the math is being handed of to the GPU… No temp increase on GPU either. Only on CPU.
I suspect it also runs single core on the ipad. But there is probably some logic/code that needs to be optimised, before it’s make multicore capable.

It’s also heavy in the non-parameric version, but not nearly as much.

160T25.shapr (370.4 KB)

Hi Jesper,

Sorry, your file won’t open for some reason. I downloaded the program twice, to ensure I had the latest version. Still no luck in opening your file.


Yeah, you need the beta version. Shapr3D Parametric Beta

Intresting, (on M2 Air, parametic) exporting to Parasolid and importing is fast, original file takes 22 second to load.

edit: can not export a STEP that works with my other CAD, but its fine to import the same STEP to Shapr3D…

My 2¢

Hi Jesper,
On my M2 iPad, it takes about 15 seconds to load. Most of that is “processing” on the load screen. I exported the pulley in x_t format and it imported quite fast.

Then I tried recreating your sketch by projecting from the imported x_t body… This did not work! For whatever reason (maybe the Shapr3d team could determine) the projected sketch is missing most of the outer circumference??

Yeah, it’s the processing part of the load that takes time. While showing the blue icon with the white worm speeding around, trying to catch it’s tail…

Just pulled out the stopwatch.
M1 Mac 23 seconds.
1st gen Ipad pro (A9X soc) 147 seconds with the parametric beta
1st gen Ipad pro (A9X soc) less that 3 seconds in the non-parametric version.

I obviously had to redraw it in the release version, but it’s pretty simple, so I’m quite sure I did the same.

@Bob3DPO Not sure why you see those gabs. I have a solid circle all the way and then the teeth added on. Extrudes nicely too…

Anyways. 600 straight lines should not be a big ask, so there must be a congestion somewhere. Too many bits trying to get through the same hole at the same time…

Hi Jesper,

Took about 40 seconds to load on a MBP with Intel i9. FYI.


1 Like

106t_release.shapr (271.0 KB)

Here is the same design in the release version format. Opens near instantly here, even on my old ipad.

Hey! Thanks for reporting this performance issue.

I did some profiling and found that indeed there are some Parasolid operations which take excessive time for otherwise simple geometry.

HBPM handles sketch fillings in a special way to be exactly reproducible with the same parameters, and something has probably gone awry in that code path. This is the reason why you don’t see the same issue in the release application.

I have created a ticket in our engineering issue tracker to check what exactly goes wrong in this case.


Thanks for checking and the feedback @David_M

On a sidenote: Is this the way/place to give this kind of feedback?? I noticed there is a “Send Beta Feedback” in testflight, but suspect that’s a standard thing. Had I gone that route you wouldn’t have gotten “test results” from the other folks.

43 seconds on low budget iPad, iPad 9

Is this the way/place to give this kind of feedback?

Yes. HBPM’s product managers check the beta forums with some regularity, we engineers also pop up here sometimes but arguably less often.

If you post about a bug/weird performance here its most likely that someone from Shapr3D will take a look at it - but every feature/issue is subject to the same prioritization system, so I cannot make any promises about timelines :slight_smile:

1 Like

Hi Shapr
I wonder if a fix for this make it into the latest beta??

I didn’t pull up the stopwatch, but it seems to still be slow. And banging away on just a single CPU core…

26 sec to open file for the first time.
After that opens instantly from projects page.
Mac mini with M2 pro.

Now that’w strange. I just stopwatched it again, and it still loads in 23 in my Mini with M1.
So M2 pro is slower?? Really weird. I guess I can’t use this as a valid excuse to buy new iron…

I don’t think so, I just didn’t measure it precise enough :slight_smile:

But is that really mater? After import it opens in less then a second.

Well. 20 some seconds once I can live with. But it’s minuttes on my ipad. So if you need to get a dimension from another design, it becomes really annoying.

Shapr admitted it shouldn’t be like this. That’s why I’m poking them. Making sure it’s not forgotten :slight_smile:


Just for info… From double click to opening +/- 4.5 seconds. (M3 Max)

@Cjacob I’m curious. Is that also just maxing out one core?? So about 100% CPU load in activity monitor…

Hello Jesper,

Not sure what you mean about one core? where to measure? Please advise.

I have the following. If pertinent? Do we to try and measure opening and capturing the data in the activity monitor?