Unable to subtract logo

I have a logo I want to subtract from a solid. Part of the logo does so. The last part fails. I can not find any issues and without more information from Shapr3D about the error, it is very hard to find the problem. Can you take a look please? It is the “Dentist” logo.

Cap - Logos


Actually, Subtract works fine. You have 3 different bodies that you want to subtract, and, you have 3 bodies you want subtracted. Just do 3 separate subtracts.


Can you subtract the RX logo from the solid cap? That is my problem.

I noticed that the logo is not touching the solid cap, therefore nothing to subtract.
Either lower the logo, or, do a Union with the 3 initial parts with the cap. Then you can do the Subtract in one step.


On a side note, how do you get it to record the pencil movement like that in the video? I can not find the option or any mention online.

Hello again,

For whatever reason, there is a problem with the root body in trying to subtract it from the cap. Perhaps because splines are involved, don’t know. I did a work around that worked. This video shows that the upper and middle tooth bodies subtract fine from the cap. The root does not subtract. The work around speaks for itself.

To get the pencil movement, go to iPad Settings and select Shapr3D. Turn on tutorial mode. Then you have restart Shapr3D before the pencil can be shown. Double click the Home button (my 2018 iPad) and remove Shapr3D. Restart and voila, it’s there.


Thank you. I have reported this type of “bug” a few times but have not heard back. I usually loft the sketch body and subtract. That is what the logo body is. I guess I did not try a large enough extrusion? Oh, and keep original … will try that from now on when I run into this. Thank you!

And thanks for the pencil tip!

You are most welcome. I usually make duplicate bodies and move and hide them for future use if needed.


I spoke too soon.

I have no idea why it didn’t work for you. See what the Shapr3D team can do to help you out.
Here, I’m returning your Shapr3D file where I made those changes- renamed of course. Use it to complete what you want to accomplish and for sharing with S3D team.


PullOneTooth.shapr (4.0 MB)

I recreated your sketch with splines, and the subtract works everytime, please find pic below

Not sure what goes wrong, but something does with the original sketch of the “root” part.

I create a construction plane over the original sketch, doubletapped on it.

Then I traced the sketch using lines and splines.

We will look into what causes the problem with the original sketch, until then, please retrace it.

Thank you both. I seem to run into this a lot with imported images or files as of late. :confused: