Very slow and shutting down again and again

I have just imported a stl assembly file which contains almost 2000 solid bodies now I try to open it and edit but Shapr3D takes too much time to open it when I try to draw a line it crashes again and again I think it cannot handle the complex assembley files

Hi Hassan,

Well, it can handle very large files, but an assembly with 2000 parts is indeed very large. I guess it was in STP format not in STL, right? If you could share it with our support, we would take a look. support@shapr3d.com

1 Like

Sent the file named cnc plasma please check it

1 Like

Hello Hassan,
We received the email but there is no file attached. If the file size is very large you can try sending it via wetransfer.com. Thank you for patience.

Yes the file is 115mb

Okay I see, you can send up to 2GB size files for free using wetransfer.com. It will be enough including the file download link in your email to suport@shapr3d.com

I am trying again and agin by wetransfer.com but sending failed every time my internet connection is good

Hello Hassan, you can also try using DropBox and let’s see if that works better.

This post was flagged by the community and is temporarily hidden.

电脑的你不会使用,那你还导出做什么呢,哈哈哈
我是用的时候,要修改参数,还是很头疼的

Hello, can you please try re-importing the design into Shapr in DWG format, lets see how this goes? Thanks for your patience.

Hi

First of all try to open exported file in software which has been used for export. Export could contain way too much not necessary objects.
Check export options for scope… export only solid bodies.

You may also try to export your assembly from Shapr3D in different format and try to import again.

Best way to work with large assemblies without killing your video processor or graphic card is to show only what you want to work on. Ages ago first computers and graphic card has limited memory so couldn’t smoothly calculate and display 3d coordinates of object with many points lines, colours, shadows etc. Nowadays we still have limitations in our devices, so same story applies, however your file is indeed large for 2019s iPads graphical processors. If you want to see relation between hardware limitations and numbers of graphical objects loaded to memory and calculated by any device or graphical processor, then try to make 100x1000 pattern of your complex geometry and enjoy warning messages or crashes.

Therefore to work efficiently on large assemblies I would suggest you to:

  • do not load everything until it is absolutely necessary.(internal geometries of subassemblies can be hidden while housing visible, keyboard can be simplified to 6 faces prism)
  • if you can export again, try to export/import large assembly as subassemblies which will be easier to select and hide,
  • if you cannot get better import file then try to make groups / subassemblies on imported geometry, then show only these you want to work on.

I bet heaviest geometries in your assembly are 1. Keyboard,2. chains at the back, 3. bearings inside motors? Try to hide elements with highest number of edges, faces as this shall make model “lighter” for graphics performance and improve your work efficiency.

I hope this helps.

Cheers

1 Like