Working with letters is a pain

So I am doing some name signs for a stable but working with the letters is plain horrible. Scaling often fails. Offset edges fails even more (you can sometime achieve it by offsetting it multiple times, till you reached the desired distance).

Also, when there is a lot of letters (multiple names), then things becomes super slow on PC. Is the PC version actually slower than using an Ipad? On PC you got to delete all sketches, because they slow you down so much, things basically grind to a halt. Deleting the sketches makes things better again (to a point).

And righ now, I can’t extrude a simple sketch. It fails (the one from the pic). And this time, i also can’t do it in steps it seems.

This happens quite regularely. Shapr fails on a operation, but then is able to do it in little steps.

Also, cpu load is basically non existent. 12 cores and shapr seems to use one. Any improvement on that front in sight?

“The sketch or filling cant be extruded” is the message on this one. The letters can be extruded though.

Oh, now it worked by extruding it 10 times the distance i need :joy: :expressionless:

And why do those transparent surfaces keep appearing or disappearing for no apparent reason? Now half of the letter lost their transparent surface, so i cant extrude them.

On other times, often one of those transparent surfaces appears and i can not delete it and it blocks my access to object surfaces i need to click. Also very annoying.

This one for example, without the sketches deleted, it is pretty much impossible to work on. The letters are a negative space in the surface, they are not on top of it.

Oh, and Shapr on PC urgently needs a way to handle the files. This mess in the design section is a total no-go. No way to manage versions, to sort them into directories. No way to sort by name or date. Also, there needs to be comfortable way to export and back up the projects in desired formats. Right now is very very bad.

Actually there is a hole bunch of glaring problems. I can list some, but the main focus at the moment is the name signs! But here we go:

-saving as 3mf or so, is a pain. Why do i have to select the format over and over again and why is the project name not the suggested name instead of “export”?

-if i export parts of a project with the new “hide all the rest” option, it often fails and exports all, if i turn the hide all option off too fast. Super annoying when exporting multi material builds for printing!

-why does it autoselect “draw line” so often, when I mostly don’t need it, in fact don’t need any of those options in that moment? On the other hand, when i press the “sketch” button, none of the options gets selected, even though that it is obvious, that one of the options will be selected.

-just a suggestion: Get rid of MS store. I use many stores (steam, epic, gog, Ubi, EA etc) and all of them work flawlessly. MS store however tends to cause problems and do funny things with the files. Very annoying and a reason to always chose an alternative, if there is one. So better get rid of it unless you are sure there won’t be alternatives. :wink:

-no copy and paste? The existing option is not a viable alternative. It does serve its purpose but can not replace ctrl-c and ctrl-v.

-what’s with those purple points, which when you select them by mistake, while selecting multiple surfaces, they deselect everything. Also quite annoying.

Well, but now back to the current problem. Name signs being a pain to work on and offset egdes driving me insane
.

Hoping you find the following video self-explanatory…

Hi,

Thanks a lot for the detailed feedback and also for the superb video.

A few comments to these points:

  • The text tool is creating relatively complex shapes, which is indeed stretching the capabilities of the geometric engine we use to its limits, resulting in performance and other problems you’ve mentioned. We are constantly working on improving these, but it’s hard to solve all issues. If you have a set of designs or just font types where it’s especially bad, please share them as it helps us focus our efforts.
  • We disable the sketch filling of the surface (that transparent layer) over and under holes in hollow bodies on purpose: a way more common use case (though not for you) would be to select the internal surface of the hole to move it, change its size etc. and the sketch layer would be in the way for that. What makes it disorienting here is that the complex curves of fonts make our detection logic fail unpredictably, so some holes will be detected (and the transparent layer removed) and some won’t (and the transparent layer shown). We’ll work on improving this logic, but a possible workaround could be to hide the body itself, which would re-enable the underlying sketch.
  • We will be releasing a significant update for the export functionality on Windows soon that would fix many of the problems you mentioned.
  • It is possible to install Shapr3D outside of the MS Store. You can check out the other options there: Shapr3D - Download for Windows We default to the MS Store as, while it has some problems, tends to work OK for the majority, and it makes upgrades seamless for them, which is super important to us as we improve the app every week. But we hear you and see the many limitations as well and we are investigating the alternatives.
  • Copy-pase is also something we plan to look into. It’s not trivial to solve as it’s quite alien to our current paradigms, but we’ll find a way to add it.
  • The purple points are the centerpoints for sketches that could be used as snapping points for different operations. But they way they work today are indeed more annoying than useful, so they’re going away in one of the next few releases.

And a few follow-up questions:

  • We couldn’t reproduce the “Isolate” & “Export” problem you mentioned: the UI should be disabled while the export is happening so there’s no way to turn it on too quickly. It’d help a lot to record a video of it, or if it happens frequently with one specific design, sharing a .shapr export of it with us.
  • When exactly is line drawing autoselected? The only time that should happen is if you use a pen with the app, but based on the video I believe you’re using a keyboard & mouse. (Also, have you checked out command search? It can help you select a given tool real quick.
1 Like

Hi @peter_gyongyosi.

Thanks so much for your response to the issues raised by @sunToxx.

Just to be clear, my own video was not intended to point out any flaws but rather to demonstrate to @sunToxx a way to circumvent any of the issues he was having with either the inability to select an underlying body through the hole of the text or to reveal the sketch where it might be missing.

I have always assumed that this behaviour was intentional and have never had an issue with it.

Regards, welshsteve

Oh, right! I indeed messed up and never checked the usernames, assuming that it was just a follow-up. You tricked me especially well by choosing Toxx as the text to demonstrate the functionality with :slight_smile: Most of my questions still apply though, with the only difference that I wouldn’t assume @sunToxx using keyboard & mouse as that’s not visible from those screenshots or the description.

1 Like

:rofl: Yes, I guess the video was a little misleading. I thought I would personalise the response video by incorporating part of @sunToxx’s username :rofl:

Thanks for the reply. Yes, mouse and keyboard on pc. Does Shapr support any display and pen devices on pc?

Two recent fonts that were problematic are Martina (the Murmel sign) and Salina (the heritage board). Yes, it becomes more problematic, the more curved the font is and the more points Shapr creates for it. Scaling, extruding and especially offset edge can become a real pain. However, mostly there are (time consuming) workarounds, like making small steps, or what steve showed in his video (thanks for that!).

I have used Shapr with mouse and keyboard for probably a couple hundred hours now, on multiple projects and there are quite a few problems to overcome when using it.

A simple version of copy and paste could simply create a copy of the selected geometry right on the place of the original one (ending with it being selected and or the copied parts being put into a folder), or with a slight offset, or preferably at mouse position on a targeted surface. I would have thought that the existing way of copying could be easily adjusted to do that. Kind of macro it, to create this result (and thus skip the performance issues related to doing it the regular way).

Hiding the body i was not aware of. I used projection as a workaround. Hiding it is definitely better though.

I will have a look at the link, thanks! Getting rid of that store would be great. I wouldn’t even mind having an auto updater start with windows or so. Everything is better than MS store :wink:

I did not have a use for the purple points, but if they serve a purpose, they could simply be moved to modifier keys. A fully customizable hotkey setup would be nice too. I am using a keypad for the left hand and one of my projects is in fact a left hand keyboard with 3dimensionally positioned keys, so being able to map functions to those, without having to change their keybinds, would be quite nice. And it is pretty much a standard for normal keyboard users too. Fix keyboard shortcuts are a bit problematic with the amount of keyboards today. I use said left hand keypads and a 60% keyboard, so regular keybinds aren’t always optimal.

Right now i can’t provide you with a shapr save, as extruding worked in the end, kind of, and there is no back button once you restarted Shapr (hope a permanen timeline is on the todo list too). Is there a place i can upload problematic files with a short description?

Maybe you can reproduce it tough. It was Martina font. The name Murmel in 70mm size. Scaled it a bit 2 times i believe (to make the end result 25cm wide, including the edge). Then I started trying to offset the edges by 17mm, which was super problematic. Clawed and improvised my way through. Then tried to extrude the result (the Murmel pic), but shapr failed. In the end after many tries it did work, extruding it like 100mm or so (happens quite often. Extrude or offset edge fails at certain distances but not at others, in no particular order). What a fight, but unfortunately, not a rare one.

Shapr is not running faster on an ipad than on a full blown desktop pc, is it?

@welshsteve thanks for the clip. Wasnt aware of the hiding trick. Adding lines is something i did too already, when using sketches imported from inkscape. Those like to fail too. Can either use a line to cut the shapes, or find our which side is problematic and redo a connection there. Projecting is also often a helpful feature, especially if you had to delete all sketches for performance reasons.

I did not have the isolate and export problem recently, as I now go slow when I do it. I think it might have been related to the performance issues, related to having tons of sketches (like in the heritage board above, with many letters) or lots of geometry (creating a new copy to work on, many times, as a workaround for not having a timeline to go back to previous versions).

Another maybe related problem was 3mf saves simply failing. Although that happened last time couple weeks ago i think. It did happen quite a lot before. I would export, go to Prusaslicer and there simply was no 3mf to import. Export it again, and there it was.

Another problem that occurs at times is 3mf files failing in Prusaslicer. I can’t remember the error message in Prusaslicer, but it would simply not create any gcode and not show any sliced object (just empty on that screen). The only way around that, is then to export the same thing again as stl. Then suddenly it works.

Not sure if and how those 3 are related.

When I highlight a surface with the mouse in 3d view and hit space, shapr opens sketch mode and selects “Line”. Which is basically never what I need at that point.

In those moments I usually dont need any tool, but try to navigate through the geometry I create. I am aware of the search as it pops up whenever I hit a wrong button, but I do not use it.

Actually the offset edge on this file fails. I made a copy in case you want it. Most of the range it simply refuses, but at a certain range it looks like this while trying to offset. On the top middle something is clearly going wrong (that curve that should not be there). I am trying to get a -2mm offset.

Edit: on the Shapr msix install, can I trigger a manual update or does it have to be reinstalled for new versions? My project files are still not easily accessible this way, I presume?

Hey,

  • Installer: I’d strongly suggest the “Install directly” option that uses AppInstaller over the MSIX bundle. The former auto-upgrades in the background and handles stuff for you. The underlying tech stack has an overlap with the MS Store, but works independent of that. You can upgrade an MSIX package, but to be honest, we are often somewhat behind on publishing new version for those, as that’s typically only chosen by folks who wouldn’t want to upgrade things frequently anyway.
  • Keybindings: Full customizability is something we’re looking at, but will likely not be the first things we do: we want to create good defaults first. But it’s indeed a frequent use-case, so we’ll take a look at that.
  • Handling fonts: As I’ve mentioned, that’s indeed a tough issue, bringing in many performance problems and bugs. We’ve addressed many of the perf problems and a few big improvements are coming in the next few weeks, but I can’t promise an exact date when we could address the other bugs. The text tool is only used by 10-20% of our users, so at this point we can’t justify prioritizing its problems over features more users would benefit from. A few small UX improvements will go out, but the fundamental issue of not handling the complex sketches it creates too well in all scenarios is something we won’t be able to focus on for at least the next few months.
  • Win vs. iPad performance: No, generally speaking the Windows version is just as performant as the iPad one. While modern iPads with Apple Silicon chips are marvels of engineering in terms of performance per wattage, but they have no chance beating beefy desktop CPUs & GPUs.
  • Export failures: If you ever have a file that you consistently cannot export as 3MF, please share it with us and we’ll look into this. The best way to do that is our support interface: https://support.shapr3d.com/hc/en-us/requests/new
  • Offset edge: Could you share that file with us on the link above, too? We’ll look into that – it might be something simpler than font problems.
  • Preselected Line tool: We activate the Line tool when zooming in to a surface to make it quicker & easier to start sketching right away. What do you typically do instead after zooming in?

I uploaded the Mona file, where offsetting the outer edge fails.

I will try the non store AppInstaller version, thanks!

It is not only the fonts feature of shapr though, importing shapes via Inkscape often leads to similar problems. This might raise the number of involved users :wink:

I do not remember which was the last 3mf file which I had to re-export as stl to use it in Prusaslicer, but if it happens again, I will upload it.

After zooming in, 95% of the times, first thing i got to do is moving the camera and that means deselecting the tool almost every single time.

Actually I found a Shapr 3mf that Prusaslicer can’t slice. Well, it’s multiple 3mf files of a multimaterial print object.

Each of the 3mf files i tried (like the bottom part of the X) does not work in Prusaslicer. The object consists of 19 bodies (because it is a multimaterial print).

I upload the x_bottom.3mf as an example?

This is one of the files where in order to simulate a timeline, I simply copy the object to the right or downwards, depending on what i change.

Just to get it right – you uploaded the affected files on our Support site, right?

One final question:

After zooming in, 95% of the times, first thing i got to do is moving the camera and that means deselecting the tool almost every single time.

If you move the camera immediately, why do you zoom in to the face? If your goal is just to get closer but remain in 3D view, the “Zoom to Selection” feature can be just as useful. It’s available from the items menu (under the ellipsis) or via command search, just by pressing z. As the name says, it zooms in so that the selected object(s) fits the viewport, but without entering 2D orthogonal mode and selecting the sketching tools.