4.10 - Section views for 2D drawings

Hi everyone!

You asked, we made sure to listen. We’re dishing up section views for 2D drawings. :rocket: Download the latest app version from our website or the App Store to slice up 3D models and explore the hidden details and surfaces inside.

On top of that, here’s a cocktail of updates for you:

  • New: You can now sketch and use guide curves to customize the surfaces of your lofted bodies.

    • iPad:
      Loft_guide_curve_iPad
    • Mac:
      Loft_guide_curve_Mac
  • New: We smartened up guide points, so you can see and snap to points that lie on a sketch plane.

  • New: You can now hide each sketching and modeling tool’s instructions that appear on screen. Just select the arrow to hide or show them.

  • New: We revamped the Help menu for iPad and added the Help button to the Mac title bar. You can find links to announcements for the latest new features, check your progress with tutorials, quick-access helpful tips in the Manual, etc.

  • Fixed: During a routine check, we found some unruly bugs so we came down hard on them. If you’re designing on the Mac with the SpaceMouse, the inner workings of the 3D mouse are now refreshed. For both iPad and Mac users, using the Shell tool and transformation tools — such as Scale and Move/Rotate — is painless now. And, we tidied up 2D drawings’ geometries feature.

7 Likes

Great work Shapr3D team :star_struck: :clap:

There also found a bug.
Exporting pdf to share doesnt work anymore. The pop-up stays grey without showing any information . Also after this action shapr becomes really slow and has to be restarted.

Can you share a screenshot?

@sander @Istvan_CEO_Shapr3D I had reported this mid July. It’s not just with PDF, it’s with other file types as well, and in the 3D modeling space, too.

Here is the post:

Oh, that’s an iOS bug unfortunately. Are you running on the lates iOS version?

@Istvan_CEO_Shapr3D I am running the current IOS version 14.7.1
I just tried various file types, in drawings and the 3D space, and the SHARE WITH option seems to be working now. :+1:t2:

Possibly Apple fixed it with an update, however I’m not sure which version I was on at the time I posted the original issue though. I do know it was current at time of posting, around July 15th.

Edit: version history appears to be 14.6 at the time I first reported.

14.7 came out shortly thereafter, and the issue seemed to persist.

I’m curious if @sander is on 14.7.0 and the fix may be on 14.7.1

This happens in the last updated version. Tested in different files. After this action Shapr becomes really slow and laggy and needs to be shut down.

IOS update, or Shapr update?

I had the exact issue as you, now that I have the latest IOS update (14.7.1) and the latest Shapr version (4.10.0) I have no issue sharing any file types via Airdrop, messages, etc. and no lag afterwards.

If both your app and iPad are up to date and its still doing it, I’m sorry, I know the frustration. It was really interupting my workflow as well.

Thank you so much for this feature, this first version is very intuitive and will fit most of the basic needs! (I’m using MacOS version of Spahr3D). :clap: :+1:

2 Likes

Here is the solution: iOS 13.6.1/14: Unable to Share Anything / Share Sheet Blank Screen on iPhone and iPad - YouTube

1 Like

These look great especially modifying the lofted bodies, and sections but I cannot see how to do these new functions. Can you show me where to look or explain them better. On sectioning, I want to see this when I am drawing in 3D but I can never work out how I can set it in at a point that I want it defaults to the one axis.
I would also like more guidance on the adjusting the lofted bodies and things.

I have found a few things out from these new updates, and found the sectioning on drawings BUT is there anyway to do a section vow on the 3D screen at a point I choose, not just on the axis when I select the section button, because if the part does not overlap the axis it does not show anything, I cannot find a tutorial on this subject.

Sure: What is Section view? – Shapr3D Help Desk

Thank you, now I know how to do this, thank you for the link. I did do a search but obviously not in the right place or way.

Updated to latest version of IOS. And updated to latest version of Shapr. It still happens.


Thanks, but it doesn’t change anything for me. The only thing I can do is reset all my general settings on the ipad, but I am a bit reluctant.

Thanks for adding the section drawing option. However after experimenting I found out some more complex models can’t be sectioned. I get the notification : something went wrong, but your design is intact?? Perhaps the section drawing option doesn’t function properly after all.

Hi,

It would be super helpful if you could share this file in .shapr format with our support@shapr3d.com team. We would like to take a look and fix the bug.