Chamfer/fillet issues

I’m continually having issues with the chamfer/fillet feature. There are inconsistencies with it working/not working. Sometimes if I change the view or reattempt the chamfer/fillet or close and reopen the program I can get it to work. I’ve attached two photos as an example. I am able to chamfer fillet one side of this object but not the other. The sides should be identical.

Thank you in advance. I’m not sure how to upload my workspace.

CAEBBC4C-093D-43BA-91DA-B4BC1A32099C 327B7693-5514-4A87-B163-5F92E4CC4802

1 Like

Hi - would you be able to send me the workspace to support@shapr3d.com?

Hi Daniel. I just emailed the .shapr file. Is this what you mean? @Daniel_Shapr3D

1 Like

Why does it in Helpdesk say to delete a chamfer or a fillet when it does not work?
I have to stretch and add to get rid of them.

It does, but sometimes it is impossible. If you can show a picture of the problematic shape, maybe I can help you.

Thank you, but in general it is an on-going problem. Once it is established, it can only…bla bla blaaa
It’d be nice if it became it’s own entity.

If you could show a few problematic shapes, I could explain why it does not work in those cases and why it works in other cases.

Just as simple as it sounds, I create a solid round, offset and pull/extrude, chamfer or fillet and then it is there to stay

Can’t heal wound! It has no way to refer to …yeah what? Something limits it’s ability to recognize it’s origin/origins.

Note - I play around with it a bit more and somehow understand a bit more but need to know more what limits a chamfer/fillet feature, boundaries etc.

Would it be hard to implement alternate chamfer angles?

No, it would be fairly straightforward, but we have higher priorities currently.

1 Like

Regarding chamfer/fillet I’ve seen now that it becomes a problem when I join (union) two solids and use the command. It can not be deleted and produces a radius which goes beyond 45 dgrees once a surface is stretched.
It does not understand that it is a radius. * I meant to say fillet, not radius.
Just a photo to show here;

I think this depends on the shape of the solids which will determine if it’s best to apply Chamfer/Fillet before or after you apply Union to the bodies.

Can you please share a short screen recording?

It’s just not something I can umderstand. Once a new body is attached the added fillet can neither be deleted or stay 90 degrees.

Just to keep it on it’s “keel” here, parts/bodies added are onto an .stl file from Maxon motors. I have not tried a completely new blank file.

Now I know a bit more.
Once a cylinder is created L-shaped (flange), an inner and an outer fillet is applied, then if larger diameter is scaled down/“shrunk” dynamically the two fillets will coincide and delete the “flat”, subsequently leading to not being retreivable and fillets undeletable.

Those fillets will just keep going “around”.

The confusion is that somehow if I minimize fillets and add a new cylinder body onto flat and Union it then the problem still is there once it initially came into place.

So,…if a new body is created in a process of playing with designs, added as an extrusion and joined with a solid, then those initial fillets can not be deleted faulty as they’ve become by own mistake and there is no way to eliminate to correct I have figured out now. Fillets will have to ONLY be applied to finished design.

This might be related to the editing limitations of the STL format. I tested this out as shown below and I’m able to delete the fillet even after I have merged the bodies using the Union tool

Shouldn’t a fillet command work like a tangent command? Once it goes out of a tangent confine it should stop in my view. The whole idea of two interpolating fillets works in this way as I understand it. Then how can it take whole different properties by not adjusting fillet radius when stretching or joining adherent solids. I.e., If the fillet “loses” a straight line such as in an attached square or cylinder wall then when remaining surface “end” is “pulled/stretched” the fillet keeps rotating around it’s axis/center. I even tried to add by extrude command but somehow it does not recognize a “new line”/wall/linear surface.

Finally figured out what the problem is. Thanks for a great development of this product, however if I could get a wish fulfilled it would be to be able to enable xyz coordinates for specific location, such as a snap point or the center of a body and ability to change in a/the pop-up window.
A Move command in other words, in World space.

I’m thinking kind of like this!

Hi, thanks for the feedback. It’s great to know you found a way around the issue.

We plan to implement the 3d snapping feature and this will help with this. There is no ETA at the moment for when this will be deployed.

1 Like

If you could give a few examples where this feature could be particularly useful, it would help us prioritize it.